Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-7920

Have TransactionTotalsPdf.pdf show the internal company show it has been generated for.

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Implemented
    • Affects Version/s: None
    • Fix Version/s: 16.11.01
    • Component/s: None
    • Labels:
      None

      Description

      The TransactionTotalsPdf.pdf currently doesn't show the name of the company it has been generated for.

      1. OFBIZ-7920-common.patch
        3 kB
        Pierre Smits
      2. OFBIZ-7920-common-v2.patch
        2 kB
        Pierre Smits

        Activity

        pfm.smits Pierre Smits added a comment -

        This patch addresses the issue.

        jacques.le.roux Jacques Le Roux added a comment -

        I was ready to commit your patch but stumbled about 2 points:

        1. Are we sure that the changes in Simple.fo.ftl are general enough? I mean did you check that they will not appear in inopportune places?
        2. Not related (shaving the yak style) but I need to understant why Eclipse tells me

          cvc-complex-type.2.4.d: Invalid content was found starting with element 'xls'. No child element is expected at this point.

          at CommonScreens.xml[491], the XSD seems OK...I'll check that...

        jacques.le.roux Jacques Le Roux added a comment -

        About 2, forgot to mention that it happens also when you comment out the

        <xls><html-template location="component://common/template/includes/Simple.xls.ftl"/></xls>

        line, weird!

        jacques.le.roux Jacques Le Roux added a comment -

        OK, this is something I can't reproduce in another file when C/Pasting the whole block

                            <html><html-template location="component://common/template/includes/Simple.ftl"/></html>
                            <xsl-fo><html-template location="component://common/template/includes/Simple.fo.ftl"/></xsl-fo>
                            <xml><html-template location="component://common/template/includes/MinimalDecorator.ftl"/></xml>
                            <text><html-template location="component://common/template/includes/MinimalDecorator.ftl"/></text>
                            <csv><html-template location="component://common/template/includes/MinimalDecorator.ftl"/></csv>
                            <xls><html-template location="component://common/template/includes/Simple.xls.ftl"/></xls>
        

        Must be a quirk in the file I can't spot!

        jacques.le.roux Jacques Le Roux added a comment -

        So the point 2 can be neglected

        pfm.smits Pierre Smits added a comment -

        Hi Jacques Le Roux,

        I will go through all the other widgets etc. where the SimpleDecorator is applied and see what the impact of the patch is.

        jacques.le.roux Jacques Le Roux added a comment -

        Thanks Pierre, that will be very helpful!

        jacques.le.roux Jacques Le Roux added a comment -

        Bump!

        pfm.smits Pierre Smits added a comment -

        Thanks for the remider, Jacques.

        The patch has grown stale with respect to the label change.

        pfm.smits Pierre Smits added a comment -

        I will provide a new patch file.

        pfm.smits Pierre Smits added a comment -

        Revised patch. Checked against most occurrences where the SimpleDecorator is used. A few weren't possible to check due to missing demo data.

        jacques.le.roux Jacques Le Roux added a comment -

        Thanks Pierre,

        Your patch is in trunk at revision: 1758091

        pfm.smits Pierre Smits added a comment -

        Thanks Jacques.


          People

          • Assignee:
            jacques.le.roux Jacques Le Roux
            Reporter:
            pfm.smits Pierre Smits
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development