Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 16.11.01
    • Component/s: start
    • Labels:
    • Sprint:
      Bug Crush Event - 21/2/2015

      Description

      Introduce unit tests to the Start component utilizing the unit tests framework introduced by Gradle

        Activity

        taher Taher Alkhateeb added a comment -

        Fixed a regression in 1757360. Essentially you cannot turn off the server after making code changes because some tests fail that depend on OFBiz not being active (turned off). These tests need to be introduced more cleanly in the integration tests suite somewhere.

        This marks the JIRA as complete.

        taher Taher Alkhateeb added a comment -

        Also a small comment, a very nice test report is generated for the unit tests in /build/reports/tests/index.html similar to the test report for integration tests in runtime/logs.

        taher Taher Alkhateeb added a comment -

        Committed the first batch of unit tests (8 tests) in r1753274 into a new file called OfbizStartupUnitTests.java and fixed minor issues in the code that were detected thanks to these tests.


          People

          • Assignee:
            taher Taher Alkhateeb
            Reporter:
            taher Taher Alkhateeb
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development

                Agile