Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 16.11.01
    • Component/s: None
    • Labels:
      None

      Description

      gradlew ofbiz

      works but not

      gradlew --stacktrace "ofbizBackgroundSecure --start"

      I get this (French sorry)

      C:\projectASF-Mars\ofbiz>gradlew --stacktrace "ofbizBackgroundSecure --start"
      Picked up JAVA_TOOL_OPTIONS: -Dfile.encoding=UTF8
      :ofbizBackgroundSecure --start FAILED
      
      FAILURE: Build failed with an exception.
      
      * Where:
      Build file 'C:\projectASF-Mars\ofbiz\build.gradle' line: 785
      
      * What went wrong:
      Execution failed for task ':ofbizBackgroundSecure --start'.
      > Cannot run program "gradlew" (in directory "C:\projectASF-Mars\ofbiz"): CreateProcess error=2, Le fichier sp├®cifi├® est introuvable
      
      * Try:
      Run with --info or --debug option to get more log output.
      
      * Exception is:
      org.gradle.api.tasks.TaskExecutionException: Execution failed for task ':ofbizBackgroundSecure --start'.
              at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeActions(ExecuteActionsTaskExecuter.java:69)
              at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.execute(ExecuteActionsTaskExecuter.java:46)
              at org.gradle.api.internal.tasks.execution.PostExecutionAnalysisTaskExecuter.execute(PostExecutionAnalysisTaskExecuter.java:35)
              at org.gradle.api.internal.tasks.execution.SkipUpToDateTaskExecuter.execute(SkipUpToDateTaskExecuter.java:68)
              at org.gradle.api.internal.tasks.execution.ValidatingTaskExecuter.execute(ValidatingTaskExecuter.java:58)
              at org.gradle.api.internal.tasks.execution.SkipEmptySourceFilesTaskExecuter.execute(SkipEmptySourceFilesTaskExecuter.java:52)
              at org.gradle.api.internal.tasks.execution.SkipTaskWithNoActionsExecuter.execute(SkipTaskWithNoActionsExecuter.java:52)
              at org.gradle.api.internal.tasks.execution.SkipOnlyIfTaskExecuter.execute(SkipOnlyIfTaskExecuter.java:53)
              at org.gradle.api.internal.tasks.execution.ExecuteAtMostOnceTaskExecuter.execute(ExecuteAtMostOnceTaskExecuter.java:43)
              at org.gradle.execution.taskgraph.DefaultTaskGraphExecuter$EventFiringTaskWorker.execute(DefaultTaskGraphExecuter.java:203)
              at org.gradle.execution.taskgraph.DefaultTaskGraphExecuter$EventFiringTaskWorker.execute(DefaultTaskGraphExecuter.java:185)
              at org.gradle.execution.taskgraph.AbstractTaskPlanExecutor$TaskExecutorWorker.processTask(AbstractTaskPlanExecutor.java:66)
              at org.gradle.execution.taskgraph.AbstractTaskPlanExecutor$TaskExecutorWorker.run(AbstractTaskPlanExecutor.java:50)
              at org.gradle.execution.taskgraph.DefaultTaskPlanExecutor.process(DefaultTaskPlanExecutor.java:25)
              at org.gradle.execution.taskgraph.DefaultTaskGraphExecuter.execute(DefaultTaskGraphExecuter.java:110)
              at org.gradle.execution.SelectedTaskExecutionAction.execute(SelectedTaskExecutionAction.java:37)
              at org.gradle.execution.DefaultBuildExecuter.execute(DefaultBuildExecuter.java:37)
              at org.gradle.execution.DefaultBuildExecuter.access$000(DefaultBuildExecuter.java:23)
              at org.gradle.execution.DefaultBuildExecuter$1.proceed(DefaultBuildExecuter.java:43)
              at org.gradle.execution.DryRunBuildExecutionAction.execute(DryRunBuildExecutionAction.java:32)
              at org.gradle.execution.DefaultBuildExecuter.execute(DefaultBuildExecuter.java:37)
              at org.gradle.execution.DefaultBuildExecuter.execute(DefaultBuildExecuter.java:30)
              at org.gradle.initialization.DefaultGradleLauncher$4.run(DefaultGradleLauncher.java:154)
              at org.gradle.internal.Factories$1.create(Factories.java:22)
              at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:90)
              at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:52)
              at org.gradle.initialization.DefaultGradleLauncher.doBuildStages(DefaultGradleLauncher.java:151)
              at org.gradle.initialization.DefaultGradleLauncher.access$200(DefaultGradleLauncher.java:32)
              at org.gradle.initialization.DefaultGradleLauncher$1.create(DefaultGradleLauncher.java:99)
              at org.gradle.initialization.DefaultGradleLauncher$1.create(DefaultGradleLauncher.java:93)
              at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:90)
              at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:62)
              at org.gradle.initialization.DefaultGradleLauncher.doBuild(DefaultGradleLauncher.java:93)
              at org.gradle.initialization.DefaultGradleLauncher.run(DefaultGradleLauncher.java:82)
              at org.gradle.launcher.exec.InProcessBuildActionExecuter$DefaultBuildController.run(InProcessBuildActionExecuter.java:94)
              at org.gradle.tooling.internal.provider.ExecuteBuildActionRunner.run(ExecuteBuildActionRunner.java:28)
              at org.gradle.launcher.exec.ChainingBuildActionRunner.run(ChainingBuildActionRunner.java:35)
              at org.gradle.launcher.exec.InProcessBuildActionExecuter.execute(InProcessBuildActionExecuter.java:43)
              at org.gradle.launcher.exec.InProcessBuildActionExecuter.execute(InProcessBuildActionExecuter.java:28)
              at org.gradle.launcher.exec.ContinuousBuildActionExecuter.execute(ContinuousBuildActionExecuter.java:81)
              at org.gradle.launcher.exec.ContinuousBuildActionExecuter.execute(ContinuousBuildActionExecuter.java:46)
              at org.gradle.launcher.daemon.server.exec.ExecuteBuild.doBuild(ExecuteBuild.java:52)
              at org.gradle.launcher.daemon.server.exec.BuildCommandOnly.execute(BuildCommandOnly.java:36)
              at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
              at org.gradle.launcher.daemon.server.exec.WatchForDisconnection.execute(WatchForDisconnection.java:37)
              at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
              at org.gradle.launcher.daemon.server.exec.ResetDeprecationLogger.execute(ResetDeprecationLogger.java:26)
              at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
              at org.gradle.launcher.daemon.server.exec.RequestStopIfSingleUsedDaemon.execute(RequestStopIfSingleUsedDaemon.java:34)
              at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
              at org.gradle.launcher.daemon.server.exec.ForwardClientInput$2.call(ForwardClientInput.java:74)
              at org.gradle.launcher.daemon.server.exec.ForwardClientInput$2.call(ForwardClientInput.java:72)
              at org.gradle.util.Swapper.swap(Swapper.java:38)
              at org.gradle.launcher.daemon.server.exec.ForwardClientInput.execute(ForwardClientInput.java:72)
              at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
              at org.gradle.launcher.daemon.server.health.DaemonHealthTracker.execute(DaemonHealthTracker.java:47)
              at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
              at org.gradle.launcher.daemon.server.exec.LogToClient.doBuild(LogToClient.java:60)
              at org.gradle.launcher.daemon.server.exec.BuildCommandOnly.execute(BuildCommandOnly.java:36)
              at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
              at org.gradle.launcher.daemon.server.exec.EstablishBuildEnvironment.doBuild(EstablishBuildEnvironment.java:72)
              at org.gradle.launcher.daemon.server.exec.BuildCommandOnly.execute(BuildCommandOnly.java:36)
              at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
              at org.gradle.launcher.daemon.server.health.HintGCAfterBuild.execute(HintGCAfterBuild.java:41)
              at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:120)
              at org.gradle.launcher.daemon.server.exec.StartBuildOrRespondWithBusy$1.run(StartBuildOrRespondWithBusy.java:50)
              at org.gradle.launcher.daemon.server.DaemonStateCoordinator$1.run(DaemonStateCoordinator.java:246)
              at org.gradle.internal.concurrent.ExecutorPolicy$CatchAndRecordFailures.onExecute(ExecutorPolicy.java:54)
              at org.gradle.internal.concurrent.StoppableExecutorImpl$1.run(StoppableExecutorImpl.java:40)
      Caused by: java.io.IOException: Cannot run program "gradlew" (in directory "C:\projectASF-Mars\ofbiz"): CreateProcess error=2, Le fichier sp├®cifi├® est introuvable
              at java_lang_ProcessBuilder$start$2.call(Unknown Source)
              at build_146dpgoos7lwgtdjesm7a07a.spawnProcess(C:\projectASF-Mars\ofbiz\build.gradle:785)
              at build_146dpgoos7lwgtdjesm7a07a$_createOfbizBackgroundCommandTask_closure38$_closure84.doCall(C:\projectASF-Mars\ofbiz\build.gradle:773)
              at org.gradle.api.internal.AbstractTask$ClosureTaskAction.execute(AbstractTask.java:554)
              at org.gradle.api.internal.AbstractTask$ClosureTaskAction.execute(AbstractTask.java:535)
              at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeAction(ExecuteActionsTaskExecuter.java:80)
              at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeActions(ExecuteActionsTaskExecuter.java:61)
              ... 68 more
      Caused by: java.io.IOException: CreateProcess error=2, Le fichier sp├®cifi├® est introuvable
              ... 75 more
      
      
      BUILD FAILED
      
      Total time: 1.294 secs
      

      This works perfefctly fine in *nix (at least Ubuntu as trunk demo shows) so it's only a minor issue because I guess very few people run OFBIz on Windows servers...

        Activity

        jacques.le.roux Jacques Le Roux added a comment -

        This works perfectly well now, closing. Thanks Taher!

        taher Taher Alkhateeb added a comment -

        Hi Jacques,

        Fixed in 1753823. I simply added .bat to the windows based version of the command

        jacques.le.roux Jacques Le Roux added a comment -

        Logically same for

        gradlew --stacktrace "ofbizBackground --start"

        ie the not secured version


          People

          • Assignee:
            taher Taher Alkhateeb
            Reporter:
            jacques.le.roux Jacques Le Roux
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development