Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 16.11.01
    • Component/s: framework
    • Labels:
      None

      Description

      Total 74 occurrence of <call-bsh> in minilang. Need to replace them with <script>groovy:

      1. OFBIZ-7765.patch
        65 kB
        Nicolas Malin
      2. OFBIZ-7765.patch
        65 kB
        Deepak Dixit
      3. OFBIZ-7765.patch
        67 kB
        Deepak Dixit

        Issue Links

          Activity

          deepak.dixit Deepak Dixit added a comment -

          Here is the patch for call-bsh to script replacement. I did not check each and every replacement, I tested some places and its working fine.

          deepak.dixit Deepak Dixit added a comment -

          Here is the update patch, excluded PartyProfileContent.js that contains local changes

          jacopoc Jacopo Cappellato added a comment -

          Thank you Deepak Dixit: your last patch looks good to me; I would suggest that you commit it to trunk to let other help to test it and then we fix any regression (if any) in the trunk.

          soledad Nicolas Malin added a comment -

          Also good to me, I update a new patch with remove callBsh class because it's unusable in few time.

          Maybe we can improve the script documentation to indicate that it can replace <call-bsh> by <script>groovy:

          soledad Nicolas Malin added a comment -

          Ok sorry deepak, Jacopo already done on OFBIZ-7763 , I'm coming after the war :/

          soledad Nicolas Malin added a comment -

          +1

          jacopoc Jacopo Cappellato added a comment -

          Thank you Nicolas Malin! I agree we should remove CallBsh after Deepak's commit: however, if you agree, I will proceed with the removal of that code and some other artifacts as in the patch I have attached to OFBIZ-7763... I am ready to commit it as soon as Deepak has completed his work.

          soledad Nicolas Malin added a comment -

          What you thanks me ! :/ for a work that I realized with less successful than you ! crazy ^^

          Don't reversing the charges, the thanks is to you and Deepak.

          Ok we wait Deepak, during this a detect some test failed, I will analyse the reason

          soledad Nicolas Malin added a comment -

          Deepak, I relaod a new patch with two correct

          revert xml header on applications/product/minilang/product/test/GroupOrderTest.xml and remove ]]> on ShoppingCartTest.xml

          now the test pass !

          jacopoc Jacopo Cappellato added a comment -

          Thank you Deepak (and Nicolas), I have committed your code in rev. 1751945

          deepak.dixit Deepak Dixit added a comment -
          rishisolankii Rishi Solanki added a comment -

          Not sure if this is right ticket to report this issue;

          When user tries to browse - https://localhost:8443/webtools/control/ServiceList
          receives following exception:

          org.ofbiz.widget.renderer.ScreenRenderException: Error rendering screen [component://webtools/widget/ServiceScreens.xml#ServiceList]: java.lang.IllegalArgumentException: Error running script at location [component://webtools/groovyScripts/service/AvailableServices.groovy]: org.ofbiz.service.GenericServiceException: Cannot locate service by name (testBsh) (Error running script at location [component://webtools/groovyScripts/service/AvailableServices.groovy]: org.ofbiz.service.GenericServiceException: Cannot locate service by name (testBsh))
          

          On further look into the issue found that testBsh service definition commented in the services_test.xml and removed from other places. But this is in use groups_test.xml and secas_test.xml of framework/common/./. After commenting both entries I'm able to browse the shared screen of service list.

          Thanks!

          deepak.dixit Deepak Dixit added a comment -

          Thanks Rishi, this has been fixed at r#1752140

          rishisolankii Rishi Solanki added a comment -

          Thanks Deepak!


            People

            • Assignee:
              deepak.dixit Deepak Dixit
              Reporter:
              deepak.dixit Deepak Dixit
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development