Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Release Branch 13.07, Release Branch 14.12, Trunk, Release Branch 15.12
    • Fix Version/s: 16.11.01
    • Component/s: product
    • Labels:
      None

      Description

      Steps to regenerate:

      • Go to Catalog --> Products
      • Select any digital product from product list
      • Go to features
      • Expire product features for any of the feature type
      • Go to product detail page of respective digital product
      • Following error is shown:
        org.ofbiz.widget.renderer.ScreenRenderException: Error rendering screen [component://ecommerce/widget/CatalogScreens.xml#product]: org.ofbiz.widget.renderer.ScreenRenderException: Error rendering screen [component://ecommerce/widget/CommonScreens.xml#main-decorator]: org.ofbiz.widget.renderer.ScreenRenderException: Error rendering screen [component://ecommerce/widget/CatalogScreens.xml#productdetail]: java.lang.IllegalArgumentException: Error running script at location [component://order/webapp/ordermgr/WEB-INF/actions/entry/catalog/ProductDetail.groovy]: org.ofbiz.service.ExecutionServiceException: Cannot build feature tree: orderFeatureList is null for orderKey=STYLE (Error running script at location [component://order/webapp/ordermgr/WEB-INF/actions/entry/catalog/ProductDetail.groovy]: org.ofbiz.service.ExecutionServiceException: Cannot build feature tree: orderFeatureList is null for orderKey=STYLE) (Error rendering screen [component://ecommerce/widget/CatalogScreens.xml#productdetail]: java.lang.IllegalArgumentException: Error running script at location [component://order/webapp/ordermgr/WEB-INF/actions/entry/catalog/ProductDetail.groovy]: org.ofbiz.service.ExecutionServiceException: Cannot build feature tree: orderFeatureList is null for orderKey=STYLE (Error running script at location [component://order/webapp/ordermgr/WEB-INF/actions/entry/catalog/ProductDetail.groovy]: org.ofbiz.service.ExecutionServiceException: Cannot build feature tree: orderFeatureList is null for orderKey=STYLE)) (Error rendering screen [component://ecommerce/widget/CommonScreens.xml#main-decorator]: org.ofbiz.widget.renderer.ScreenRenderException: Error rendering screen [component://ecommerce/widget/CatalogScreens.xml#productdetail]: java.lang.IllegalArgumentException: Error running script at location [component://order/webapp/ordermgr/WEB-INF/actions/entry/catalog/ProductDetail.groovy]: org.ofbiz.service.ExecutionServiceException: Cannot build feature tree: orderFeatureList is null for orderKey=STYLE (Error running script at location [component://order/webapp/ordermgr/WEB-INF/actions/entry/catalog/ProductDetail.groovy]: org.ofbiz.service.ExecutionServiceException: Cannot build feature tree: orderFeatureList is null for orderKey=STYLE) (Error rendering screen [component://ecommerce/widget/CatalogScreens.xml#productdetail]: java.lang.IllegalArgumentException: Error running script at location [component://order/webapp/ordermgr/WEB-INF/actions/entry/catalog/ProductDetail.groovy]: org.ofbiz.service.ExecutionServiceException: Cannot build feature tree: orderFeatureList is null for orderKey=STYLE (Error running script at location [component://order/webapp/ordermgr/WEB-INF/actions/entry/catalog/ProductDetail.groovy]: org.ofbiz.service.ExecutionServiceException: Cannot build feature tree: orderFeatureList is null for orderKey=STYLE)))
        
      1. OFBIZ-7212.patch
        1 kB
        Anurag Chandak

        Issue Links

          Activity

          anurag.chandak@hotwaxsystems.com Anurag Chandak added a comment -

          Thanks Arun Patidar!

          arunpati Arun Patidar added a comment -

          Committed changes in trunk at rev: 1751030
          in 15.12 at rev: 1751031
          in 14.12 at rev: 1751032
          in 13.07 at rev: 1751033

          Thanks Anurag Chandak for your contribution.

          anurag.chandak@hotwaxsystems.com Anurag Chandak added a comment -

          The cause of this issue is when service getProductFeatureSet is used to get the list of feature, then all the features are stored in the list from "ProductFeatureAndAppl". Feature list contains all the features including expired ones. So need to do filter by date on ProductFeatureAndAppl.

          I am attaching the patch for the same.


            People

            • Assignee:
              arunpati Arun Patidar
              Reporter:
              anurag.chandak@hotwaxsystems.com Anurag Chandak
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development