Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-7203

Empty Requirement Id and Product Id fields when generating pdf for Approved Product Requirements

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Trunk
    • Fix Version/s: 16.11.01
    • Component/s: order
    • Labels:
      None

      Description

      Steps to regenerate:
      1) Go to Order -> Requirements -> Approved Product Requirements
      2) Generate pdf (Systems should have some approved product requirements)
      3) Pdf showing empty Requirement Id and Product Id fields.

        Activity

        lodhiravi Ravi Lodhi added a comment -

        I looked around this issue and found that the pdf is generating using list form. This contains hyperlink for Requirement Id and Product Id. The problem is in the "makeHyperlinkString" macro which is used to convert hyperlink content for the pdf.

        As this pdf is working fine with all the previous releases except trunk, so I explored around the functionality in 13.07 and found that the "makeHyperlinkString" in trunk is having <fo:block/> in place of <@makeBlock linkStyle description />

        13.07 code

        <#macro makeHyperlinkString linkStyle hiddenFormName event action imgSrc title alternate linkUrl targetWindow description confirmation><@makeBlock linkStyle description /></#macro>
        

        trunk code

        <#macro makeHyperlinkString linkStyle hiddenFormName event action imgSrc title targetParameters alternate linkUrl targetWindow description confirmation uniqueItemName="" height="" width="" id=""><fo:block/><!--link--></#macro>
        

        After replacing the <fo:block/> with <@makeBlock linkStyle description /> the pdf is working fine.

        Uploaded the patch with these changes for review.

        toashishvijay Ashish Vijaywargiya added a comment -

        Thanks Ravi for the contribution. Your changes are committed in trunk at r1747516.


          People

          • Assignee:
            toashishvijay Ashish Vijaywargiya
            Reporter:
            lodhiravi Ravi Lodhi
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development