Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-7075

Sending mail button from viewProfile doesn't work

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Trunk
    • Fix Version/s: 16.11.01
    • Component/s: party
    • Labels:

      Description

      Hi,

      The button 'send mail' from the profile overview page is not working.

      How to reproduce :
      1) Go to the party component
      2) Search for an party with a registered mail address
      3) Go to the profile page : i.e. : https://localhost:8443/partymgr/control/viewprofile?partyId=admin
      4) Click on the "send mail" button
      5) Nothing happens

      Problem :
      When checking the target of the button "send mail", we can see that a "@" symbol appears. The target corresponds to the form name just above (the one containing the email address). Thus, the form name contains the symbol too.
      This symbol seems to be forbidden in javascript naming (a warning is risen by the browser console) and this prevents the execution of the javascript.
      When manually deleting this symbol in both the name of the form and the target of the button, the javascript works fine.

      Root of the problem :
      In the "Contact.ftl" template, which creates this form, we can see that the name of the form and the target are created from the 'contactMech.infoString' (the email address in this case). A parsing of the string is done to remove the "@" symbol and the "." . The dot is deleted but not the at symbol. The problem comes from the encoding of the symbol. The parsing looks for a html coding "@" but in the source code of the page, the symbol is in UCS "@" .

      I'll provide the patch adding a replace with this encoding.

      Thanks,
      Florian

      1. OFBIZ-7075.patch
        2 kB
        Montalbano Florian

        Activity

        jacques.le.roux Jacques Le Roux added a comment -

        Thanks Florian,

        Your patch is in trunk r1744571.

        No needs to backport, all previous releases branches work well


          People

          • Assignee:
            jacques.le.roux Jacques Le Roux
            Reporter:
            Florian M Montalbano Florian
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development