Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-6957

jquery plugin jgrowl is loaded before jquery in ecommerce

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Trunk
    • Fix Version/s: 16.11.01
    • Component/s: ecommerce
    • Labels:
      None

      Description

      jgrowl, a jquery plugin, cannot run correctly as jgrowl is loaded before jquery

        Activity

        Hide
        jacques.le.roux Jacques Le Roux added a comment -

        Nobody else complained. In which circumstances did you get this issue?
        You need to give us more details, please follow this scenario (at least relevant parts)

        Why

        • What you were looking for
        • How did you try to achieve it
        • What did you expect as results
        • And what you really got

        How

        1. What you did (including detailed steps to reproduce)
        2. What you expected to happen
        3. What actually happened (including exact quotes of error messages, etc)
        4. If possible provide an URL

        Last but not least: Release.revision? (see bottom of backend pages, if nothing run ant svninfo)

        Show
        jacques.le.roux Jacques Le Roux added a comment - Nobody else complained. In which circumstances did you get this issue? You need to give us more details, please follow this scenario (at least relevant parts) Why What you were looking for How did you try to achieve it What did you expect as results And what you really got How What you did (including detailed steps to reproduce) What you expected to happen What actually happened (including exact quotes of error messages, etc) If possible provide an URL Last but not least: Release.revision? (see bottom of backend pages, if nothing run ant svninfo)
        Hide
        jamesyong James Yong added a comment -

        I am using SVN revision 1735923

        OFBiz is running on a Window 7 computer

        Using firefox with firebug enabled, i accessed the following url:

        https://127.0.0.1:8443/ecommerce

        From firebug console, one of the errors found is

        "NetworkError: 404 Not Found - https://127.0.0.1:8443/contentimages/contentForum.css"

        Then I viewed the page source and saw the following

        ...
        <link rel="stylesheet" href="/images/jquery/plugins/jquery-jgrowl/1.4.1/jquery.jgrowl.min.css" type="text/css"/>
        <link rel="stylesheet" href="/ecommerce/images/blog.css" type="text/css"/>
        <link rel="stylesheet" href="/images/ecommain.css" type="text/css"/>
        <link rel="stylesheet" href="/contentimages/contentForum.css" type="text/css"/>
        <script type="text/javascript" src="/images/jquery/plugins/jquery-jgrowl/1.4.1/jquery.jgrowl.min.js"></script>
        <script type="text/javascript" src="/images/jquery/plugins/Readmore.js-master/readmore.js"></script>
        <script type="text/javascript" src="/images/jquery/jquery-1.11.0.min.js"></script>
        <script type="text/javascript" src="/images/jquery/jquery-migrate-1.2.1.js"></script>
        <script type="text/javascript" src="/images/jquery/plugins/validate/jquery.validate.min.js"></script>
        <script type="text/javascript" src="/images/jquery/ui/js/jquery-ui-1.10.3.min.js"></script>
        ...

        I conclude that jgrowl is loaded before jquery.
        There is no such error when I accessed other modules.

        Show
        jamesyong James Yong added a comment - I am using SVN revision 1735923 OFBiz is running on a Window 7 computer Using firefox with firebug enabled, i accessed the following url: https://127.0.0.1:8443/ecommerce From firebug console, one of the errors found is "NetworkError: 404 Not Found - https://127.0.0.1:8443/contentimages/contentForum.css " Then I viewed the page source and saw the following ... <link rel="stylesheet" href="/images/jquery/plugins/jquery-jgrowl/1.4.1/jquery.jgrowl.min.css" type="text/css"/> <link rel="stylesheet" href="/ecommerce/images/blog.css" type="text/css"/> <link rel="stylesheet" href="/images/ecommain.css" type="text/css"/> <link rel="stylesheet" href="/contentimages/contentForum.css" type="text/css"/> <script type="text/javascript" src="/images/jquery/plugins/jquery-jgrowl/1.4.1/jquery.jgrowl.min.js"></script> <script type="text/javascript" src="/images/jquery/plugins/Readmore.js-master/readmore.js"></script> <script type="text/javascript" src="/images/jquery/jquery-1.11.0.min.js"></script> <script type="text/javascript" src="/images/jquery/jquery-migrate-1.2.1.js"></script> <script type="text/javascript" src="/images/jquery/plugins/validate/jquery.validate.min.js"></script> <script type="text/javascript" src="/images/jquery/ui/js/jquery-ui-1.10.3.min.js"></script> ... I conclude that jgrowl is loaded before jquery. There is no such error when I accessed other modules.
        Hide
        jacques.le.roux Jacques Le Roux added a comment -

        OK, thanks for your effort!

        Show
        jacques.le.roux Jacques Le Roux added a comment - OK, thanks for your effort!
        Hide
        jacques.le.roux Jacques Le Roux added a comment -

        Oops, I reopen

        Show
        jacques.le.roux Jacques Le Roux added a comment - Oops, I reopen
        Hide
        jacques.le.roux Jacques Le Roux added a comment -

        Thanks for your report James,

        Fixed in trunk at revision 1736614.

        Show
        jacques.le.roux Jacques Le Roux added a comment - Thanks for your report James, Fixed in trunk at revision 1736614.

          People

          • Assignee:
            jacques.le.roux Jacques Le Roux
            Reporter:
            jamesyong James Yong
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development