Copying Jacopo's comment from dev list:
There are indeed some data model inconsistencies in this area.
After reviewing the commit (817605) that introduced the field productWeight
I think that the following applies:
"weight" should be used to specify the "shipping weight" of the product
"productWeight" should be used to specify the actual weight of the product.
However since its introduction, productWeight was never used and "weight"
has been used both to specify the shipping weight and to specify the actual
How can we fix this situation? I see two options:
1) review all usages of "weight" and fix according to the definition above
2) rename "productWeight" into "shippingWeight" and fix the codebase to use
this field only when the shipping weight is required and use "weight" in
all the other cases.
Maybe #2 would be easier to implement and would have a limited impact on