Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-6461

Resynchronise template macro form xml, text, csv and fo from html

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Implemented
    • Affects Version/s: Trunk
    • Fix Version/s: 16.11.01
    • Component/s: None
    • Labels:
      None

      Description

      The MacroFormTemplate for render language xml, csv, text and fo aren't the same than html.

      1. OFBIZ-6461.patch
        49 kB
        Nicolas Malin
      2. OFBIZ-6461.patch
        46 kB
        Nicolas Malin
      3. OFBIZ-6461.patch
        32 kB
        Nicolas Malin

        Activity

        soledad Nicolas Malin added a comment -

        I finish the macro synchronization but I don't realize the area to validate all like webtools/control/WebtoolsLayoutDemo

        Maybe on the next step

        soledad Nicolas Malin added a comment -

        Second step.

        I added four buttons on WebLayoutDemo menu to view through pdf, xml, text and csv. This permit to test most of present ftl macro on layout demo.

        I also added two tags on plateform-specific : text and csv.

        The third step will be correct menu label and better information on each view

        soledad Nicolas Malin added a comment -

        Third step, I added labels now the last step will be adding test case on widget component to detect any regression on render process

        jacques.le.roux Jacques Le Roux added a comment -

        Interesting Nicolas (did not get a chance to look at it in details yet)!

        soledad Nicolas Malin added a comment -

        I create quickly a video if other people want understand where I work

        https://cloud.nereide.fr/public.php?service=files&t=960280d5307f03a8209a14d80d7ffff5 (IPV6)

        I don't load the video on jira because is more than 10Mo

        soledad Nicolas Malin added a comment -

        Arf sorry I didn't change the locale, the video is in french :/

        soledad Nicolas Malin added a comment -

        Done on trunk at revision 1685124

        soledad Nicolas Malin added a comment -

        The last commit is not correct, I revert and resend the correct patch.

        Done on trunk at revision 1685133

        soledad Nicolas Malin added a comment -

        the bots is green now a close


          People

          • Assignee:
            soledad Nicolas Malin
            Reporter:
            soledad Nicolas Malin
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development