Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-6300

Compiler-Error with JDK 1.8 and source compatibility 1.8

    XMLWordPrintableJSON

    Details

    • Sprint:
      Community Day 2 - 2015

      Description

      I just found another error compiling the code with JDK 1.8 with source code compatibility switched to 1.8 in my eclipse workspace. The external ant build is working because there is java version 1.7 defined as target in the macros.xml.

      The error is an issue regarding generics in EntityFieldMap.java.

      I will provide a patch her soon.

      The code is the same in the release branches.

        Attachments

        1. OFBIZ-6300-EntityFieldMap.patch
          1 kB
          Martin Becker

          Issue Links

            Activity

              People

              • Assignee:
                mbrohl Michael Brohl
                Reporter:
                mbecker Martin Becker
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: