Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-6261

locationresolvers.properties is missing

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 16.11.01
    • Component/s: None
    • Labels:
      None

      Description

      during ofbiz startup

      ...console output...
      2015-04-17 17:58:18,166 |main |CatalinaContainer |I| Creating context [bluelight]
      2015-04-17 17:58:18,166 |main |CatalinaContainer |I| Creating context [bizznesstime]
      2015-04-17 17:58:18,166 |main |CatalinaContainer |I| Creating context [images]
      2015-04-17 17:58:18,166 |main |CatalinaContainer |I| Creating context [webtools]
      Exception thrown while loading locationresolvers.properties: java.lang.IllegalStateException: Exception thrown while reading debug.properties: java.lang.IllegalStateException: locationresolvers.properties not found
      2015-04-17 17:58:18,800 |main |SSLImpl |I| SSLImpl loaded; using custom ServerSocketFactory
      2015-04-17 17:58:19,045 |0.0.0.0-startStop-1 |ServiceDispatcher |I| Registering dispatcher: ebay
      2015-04-17 17:58:19,045 |0.0.0.0-startStop-1 |ServiceContainer |I| Created new dispatcher: ebay

        Activity

        wt Wai added a comment -

        not really a problem. modified UtilProperties.createProperties() to return a null when locationresolvers.properties file is missing.
        Also added a warning message.

        adrianc@hlmksw.com Adrian Crum added a comment -

        Thank you for working on this, but there is a problem with your patch. The UtilProperties.createProperties() JavaDoc says:

        "This method is intended for low-level framework classes that need to read properties files before OFBiz has been fully initialized."

        Your patch introduces a Debug.logWarning method call in low-level code where logging has not been initialized.

        I will fix this myself. Thank you for the bug report and leading me to the cause of the problem.

        adrianc@hlmksw.com Adrian Crum added a comment -

        Fixed in rev 1674453.


          People

          • Assignee:
            adrianc@hlmksw.com Adrian Crum
            Reporter:
            wt Wai
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development