Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-6234

catalog main page show freemarker exception

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 16.11.01
    • Component/s: framework
    • Labels:
      None

      Description

      go to ... https://localhost:8443/catalog/control/main

      console output...
      2015-04-08 14:31:32,760 |http-bio-8443-exec-3 |ServiceDispatcher |T| Sync service [catalog/getVisualThemeResources] finished in [1] milliseconds
      2015-04-08 14:31:32,887 |http-bio-8443-exec-3 |runtime |E| Error executing FreeMarker template
      freemarker.core._MiscTemplateException: Can't compare values of these types. Allowed comparisons are between two numbers, two strings, two dates, or two booleans.
      Left hand operand is a boolean (wrapper: f.t.TrueTemplateBooleanModel).
      Right hand operand is a string (wrapper: f.t.SimpleScalar).
      The blamed expression:
      ==> presentation == "window" [in template "component://widget/templates/htmlFormMacroLibrary.ftl" at line 664, column 42]


      FTL stack trace ("~" means nesting-related):

      • Failed at: #elseif presentation?has_content && p... [in template "component://widget/templates/htmlFormMacroLibrary.ftl" in macro "renderLookupField" at line 664, column 5]
      • Reached through: @renderLookupField name, formName, fi... [in template "component://common/webcommon/includes/htmlTemplate.ftl" in macro "lookupField" at line 40, column 5]
      • Reached through: @htmlTemplate.lookupField value="\${r... [in template "component://product/webapp/catalog/find/keywordsearchbox.ftl" at line 43, column 7]

        at freemarker.core.EvalUtil.compare(EvalUtil.java:300) ~[freemarker-2.3.22.jar:2.3.22]
        at freemarker.core.EvalUtil.compare(EvalUtil.java:112) ~[freemarker-2.3.22.jar:2.3.22]

        Activity

        jacques.le.roux Jacques Le Roux added a comment -

        Weirdly I had that fixed in the custom project where I 1st implemented the tabindex but did not backport this fix :/ I will check further...

        jacques.le.roux Jacques Le Roux added a comment -

        Thanks Wai, fixed at revision 1672252.

        jacques.le.roux Jacques Le Roux added a comment -

        Oops wrong, forgot to login

        jacques.le.roux Jacques Le Roux added a comment -

        I cannot reproduce, are you sure you are using trunk head?


          People

          • Assignee:
            jacques.le.roux Jacques Le Roux
            Reporter:
            wt Wai
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development