Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Release Branch 14.12, Trunk, 12.04.05
    • Fix Version/s: 14.12.01, 15.12.01
    • Component/s: webpos
    • Labels:
      None
    • Sprint:
      Community Day 4 - 2015

      Description

      At webpos/control/Login the payGiftCard F4 button incorrectly uses label WebPosShortcutF5 (Pay Pin) when it should be using WebPosShortcutF6. The same mismatch applies to all buttons higher than F4 and should be incremented by 1 as well.

      1. OFBIZ-6226-1412.patch
        8 kB
        Suraj Khurana
      2. OFBIZ-6226-1204.patch
        6 kB
        Suraj Khurana
      3. OFBIZ-6226.patch
        2 kB
        Christian Carlow
      4. OFBIZ-6226.patch
        8 kB
        Suraj Khurana

        Issue Links

          Activity

          deepak.dixit Deepak Dixit added a comment -

          Hi Christian Carlow,

          Can use rearrange the function key instead of changing the UiLabels or can update the UiLabel as well?
          As its confusing to use uiLabelMap.WebPosShortcutF6 for shourtcust key f5 and similar for other keys.

          jacques.le.roux Jacques Le Roux added a comment -

          Also please see my last comment at OFBIZ-5241

          suraj.khurana Suraj Khurana added a comment -

          Here is the updated patch.
          IMO we can close this one after applying this patch.
          We can continue discussion related to use of function keys at OFBIZ-5241.

          suraj.khurana Suraj Khurana added a comment -

          Patch for -r14.12

          mridul.pathak Mridul Pathak added a comment -

          Fixed in,

          • Trunk - r1720910
          • 14.12 - r1720916
          • 12.04 - r1720930
          mridul.pathak Mridul Pathak added a comment -

          Thanks Christian for reporting the issue and providing the initial patch. Thanks Suraj for the improved patch.

          mridul.pathak Mridul Pathak added a comment -

          Jacques,

          I agree with your comments on OFBIZ-5241. I think we can close this issue and continue the discussion there.

          jacques.le.roux Jacques Le Roux added a comment -

          I reverted because Something went wrong. There are duplicated labels now, better redo correctly, so reverted at:

          Trunk - r1726529
          14.12 - r1726539
          12.04 - r1726540

          jacques.le.roux Jacques Le Roux added a comment -

          I forgot this was committed before R15.12 creation, so it needs to be reverted there also, done at revision: 1729098

          jacques.le.roux Jacques Le Roux added a comment -

          Hi Jacopo, I saw you put the status as resolved but actually I reverted the commits because there were duplicate labels and we agreed about this issue being kind of a duplicate of OFBIZ-5241. So I reopened, and will link it to OFBIZ-5241.

          jacques.le.roux Jacques Le Roux added a comment -

          This was finally fixed with OFBIZ-7144. To be checked though, is there still a mismatch?


            People

            • Assignee:
              mridul.pathak Mridul Pathak
              Reporter:
              ofbizzer Christian Carlow
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development

                  Agile