Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-6124

Have a better layout design of the chart.rptdesign

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: Trunk
    • Fix Version/s: 16.11.01
    • Component/s: birt
    • Labels:

      Description

      Having a better layout design in chart.rptdesign shows better what the capabilities of the component are.

      1. Chrome local.png
        18 kB
        Jacques Le Roux
      2. Chrome trk demo.png
        14 kB
        Jacques Le Roux
      3. FF local.png
        13 kB
        Jacques Le Roux
      4. OFBIZ-6124-BirtChartReport.patch
        76 kB
        Pierre Smits
      5. OFBIZ-6124-BirtChartReport-v2.patch
        75 kB
        Pierre Smits

        Activity

        pfm.smits Pierre Smits added a comment -

        This patch addresses the issue.

        jacques.le.roux Jacques Le Roux added a comment -

        I see no problems with that, looks indeed better.

        I have a question. on FF locally I get this error about plugin

        the same works on Chrome

        Any idea about the plugin I could miss?

        Also weird, with Chrome the trunk demo fails also

        pfm.smits Pierre Smits added a comment -

        So, there is a browser plugin dependency. Can you list the version that failed the test?

        jacques.le.roux Jacques Le Roux added a comment -

        I always use last versions, currently FF 36 & Chrome 40.0.2214.115 m (pfew). The weird part is chrome on trunk is not working the same than locally :-o

        pfm.smits Pierre Smits added a comment -

        I don't have any issues against local on my Mac with OSX 10.9.5 with following browsers:

        • Firefox 35.0.1
        • Chrome 40.0.2214.115
        • Safari 7.1.3

        Nor do I have any issues against trunk.

        Even with Firefox 36.0 I don't have issues (local and against trunk).

        jacques.le.roux Jacques Le Roux added a comment -

        Maybe Windows 7 then... I will check that, found this so far
        http://www-01.ibm.com/support/docview.wss?uid=swg21652346
        https://jazz.net/forum/questions/48942/birt-on-rtc-30-missing-image-display-plugin

        So rendering png instead of svg could do it, I will try.

        Ha, it seems updating Birt from 3.4.2 to at least 4.2.1 would do it but this might be a problem, I remember Chatree telling me something about that.

        jacques.le.roux Jacques Le Roux added a comment -

        Pierre,

        Please clean-up your patch: license header missing, and maybe some other unecessary changes, hard to tell. Did you build with a tool?

        pfm.smits Pierre Smits added a comment -

        I will do that. I see what you mean.

        Well, I did it with a fairly standard Eclipse Luna (the IDE for Java and Report Developers).

        Thanks for checking.

        jacques.le.roux Jacques Le Roux added a comment -

        Happens, I have no problems with Luna so far, it's you setting.
        Check https://cwiki.apache.org/confluence/display/OFBIZ/Eclipse+Tips and your setting, even following those tips is not straightforward

        But you did not answer me, was it built or hand made?

        pfm.smits Pierre Smits added a comment -

        My apologies, Jacques. I must have missed that question.

        No, it was not hand made. I just added a table to the design, moved the charts and adjusted some labels.
        Chances are that Eclipse did all the stuff due to version changes.

        I will have a better look today, but I did a compare against repo yesterday evening and I noticed the licence was removed.
        I will provide a new one.

        I see a reference to version 2.5.1 in the file. That could be the birt version when the file was originally made. I am on 4.x

        Best regards,

        Pierre

        pfm.smits Pierre Smits added a comment - - edited

        This patch is an improved version. It now doesn't remove the licence header. Note the difference in Eclipse Designer version.

        That may be the cause of the numerous changes throughout the file. I only added a table, moved the diagrams in there and modified some labels.

        jacques.le.roux Jacques Le Roux added a comment -

        Thanks Pierre,

        Your patch is in trunk at revision: 1664276

        For person interested: look at https://cwiki.apache.org/confluence/display/OFBIZ/Using+BIRT+with+OFBiz

        jacques.le.roux Jacques Le Roux added a comment -

        BTW a weird stuff is https://localhost:8443/birt/control/chartReport works correctly, no plugin complaint in FF

        pfm.smits Pierre Smits added a comment -

        Thanks, Jacques.

        pfm.smits Pierre Smits added a comment -

        Could that be due to the differences between the Eclipse birt designer version and the runtime version in trunk?


          People

          • Assignee:
            pfm.smits Pierre Smits
            Reporter:
            pfm.smits Pierre Smits
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development