Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-6060

We can no longer reset services definitions by clearing caches

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Trunk, 14.12.01
    • Fix Version/s: 16.11.01
    • Component/s: framework
    • Labels:
      None

      Description

      Rupert Howell told me that between the middle of 2014 and the end of October we lost the possiblity to reset services definitions by clearing caches (or simply the service caches: service.ModelServiceMapByModel and service.ServiceConfig).

      I did some research and I found it is due to http://svn.apache.org/viewvc?view=revision&revision=r1622256

      I did not digg further.

        Activity

        adrianc@hlmksw.com Adrian Crum added a comment - - edited

        Are you sure that revision is the cause of the regression? All I did was move the cache from one class to another.

        jacques.le.roux Jacques Le Roux added a comment -

        Yes, just revert it and you will see. There are maybe other things involved but I highly doubt.

        adrianc@hlmksw.com Adrian Crum added a comment -

        Fixed in rev 1657714. Thanks!

        jacques.le.roux Jacques Le Roux added a comment -

        I reverted in R14.12 at r1657749


          People

          • Assignee:
            adrianc@hlmksw.com Adrian Crum
            Reporter:
            jacques.le.roux Jacques Le Roux
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development