Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-6026

Creating a QuoteRole doesn't return to overview of QuoteRoles

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: Trunk
    • Fix Version/s: 16.11.01
    • Component/s: order
    • Labels:

      Description

      Currently, when adding a QuoteRole to a Quote the user stays in the screen associated with 'EditQuoteRole'. Thus the user has no confirmation that the QuoteRole is added successfully.

      It is better to show the overviews of the quote roles.

      1. OFBIZ-6026-15.12.patch
        4 kB
        Yashwant Dhakad
      2. OFBIZ-6026-OrderQuoteRoles.patch
        1 kB
        Pierre Smits
      3. OFBIZ-6026-trunk.patch
        4 kB
        Yashwant Dhakad

        Issue Links

          Activity

          pfm.smits Pierre Smits added a comment -

          This patch addresses the issue.

          yashwant.dhakad Yashwant Dhakad added a comment -

          Verified the patch and found that success message not shown on the screen, so updated the patch and now shown the success message when added role successfully.

          yashwant.dhakad Yashwant Dhakad added a comment -

          Here are the patches for trunk and vendor 15.12 branches.

          jacques.le.roux Jacques Le Roux added a comment -

          Thanks Yashwant,

          Your slightly modified patch is in trunk at revision: 1746290

          I moved the party field line to have the lookup show. Note: in case of error the message is still awful, not a big deal

          FYI: when the patches are "the same" you don't need to provide a patch for releases branches, we can easily backport. Anyway we normally don't backport improvements (because of possible regressions) and I'll not backport this one. Also please create your patch based on trunk HEAD, there was a small fuzz factor to be applied for QuoteServices.xml.

          yashwant.dhakad Yashwant Dhakad added a comment -

          Thanks, Jacques. I will take care of all these suggestions in future.


            People

            • Assignee:
              jacques.le.roux Jacques Le Roux
              Reporter:
              pfm.smits Pierre Smits
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development