Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-6022

Menu items with parent-portal-page-value="${parameters.<ParameterValue>}" are not accessible

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Trunk
    • Fix Version/s: 16.11.01
    • Component/s: myportal
    • Labels:
      None

      Description

      When accessing the My Portal application in a trunk setup, the menu items can't be accessed.

      This seems to be a degradation in functionality, as it is possible in R12.x
      For comparison purposes:

        Activity

        Hide
        pfm.smits Pierre Smits added a comment -

        The menu-item is the following:

        <menu-item name="main" parent-portal-page-value="${parameters.parentPortalPageId}"/>
        

        So it must have something to do with the 'parent-portal-page-value' element

        Show
        pfm.smits Pierre Smits added a comment - The menu-item is the following: <menu-item name= "main" parent-portal-page-value= "${parameters.parentPortalPageId}" /> So it must have something to do with the 'parent-portal-page-value' element
        Hide
        pfm.smits Pierre Smits added a comment -

        Chang the subject to make it more generic, though only used in EXAMPLE and MYPORTAL

        Changed the priority level to Critical.

        Show
        pfm.smits Pierre Smits added a comment - Chang the subject to make it more generic, though only used in EXAMPLE and MYPORTAL Changed the priority level to Critical.
        Hide
        pfm.smits Pierre Smits added a comment -

        I did some further checking and the rendering of the menu-items in MyPortal (due to <menu-item name="main" parent-portal-page-value="$

        {parameters.parentPortalPageId}

        "/> ) still worked perfectly in R14.12, baed on commit 1653457.

        Show
        pfm.smits Pierre Smits added a comment - I did some further checking and the rendering of the menu-items in MyPortal (due to <menu-item name="main" parent-portal-page-value="$ {parameters.parentPortalPageId} "/> ) still worked perfectly in R14.12, baed on commit 1653457.
        Hide
        adrianc@hlmksw.com Adrian Crum added a comment -

        Fixed in rev 1653597. Thanks!

        Show
        adrianc@hlmksw.com Adrian Crum added a comment - Fixed in rev 1653597. Thanks!
        Hide
        pfm.smits Pierre Smits added a comment -

        Thanks, Adrian.

        Show
        pfm.smits Pierre Smits added a comment - Thanks, Adrian.

          People

          • Assignee:
            adrianc@hlmksw.com Adrian Crum
            Reporter:
            pfm.smits Pierre Smits
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development