Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-5705

cloneWorkEffortPartyAssignments doesn't work

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Implemented
    • Affects Version/s: Release Branch 11.04, Trunk
    • Fix Version/s: 16.11.01
    • Component/s: manufacturing
    • Labels:
      None
    • Sprint:
      Bug Crush Event - 21/2/2015

      Description

      The function cloneWorkEffortPartyAssignments in src/org/ofbiz/manufacturing/jobshopmgt/ProductionRunServices.java doesn't work, because no party can be assigned to a Routing Task.

        Issue Links

          Activity

          diveshdut Divesh Dutta added a comment -

          I think this is not a bug.

          If Routing task does not have any party assigned to it, then when you create Production Run from screen, it will not make party assignments for production tasks. If you have WorkEffortPartyAssignment data set up for Routing task, then when you create Production Run then cloneWorkEffortPartyAssignments will surely create WorkEffortPartyAssignments .

          So I think What Pierre Smits meant here is there is no UI available in OOTB OFBiz to assign Party to a Routing task, when you are creating a Routing task. And this is an improvement and not a bug.

          So Ashish Vijaywargiya, Could you please change type of this ticket to an improvement?

          toashishvijay Ashish Vijaywargiya added a comment -

          Based on Divesh's comment changing its type to Improvement.

          amardeepsj Amardeep Singh Jhajj added a comment -

          IMO, this ticket can be automatically resolved once we done with OFBIZ-5852.

          pandeypranay Pranay Pandey added a comment -

          Hi Amardeep Singh Jhajj,

          Yes you are right. Closing this ticket now.

          pandeypranay Pranay Pandey added a comment -

          Thanks Pierre Smits for reporting the issue, thanks Divesh Dutta for the research and comment, thanks Ashish Vijaywargiya and Amardeep Singh Jhajj for your comments. Now as OFBIZ-5852 is closed, we can safely mark this one complete as well.


            People

            • Assignee:
              pandeypranay Pranay Pandey
              Reporter:
              pfm.smits Pierre Smits
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development

                  Agile