Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-5447

.LoginWorker#logout leads to error in tenant specific ecommerce component

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 14.12.01, 16.11.01
    • Component/s: ecommerce
    • Labels:
      None
    • Sprint:
      Bug Crush Event - 21/2/2015

      Description

      In a tenant specific ecommerce application I have set following:
      in the ofbiz-component.xml

      <webapp name="mytenant-ecommerce"
      title="mytenant-ecommerce"
      server="default-server"
      location="webapp/ecommerce"
      mount-point="/mytenant-ecommerce"
      app-bar-display="false"
      />

      In the accompanying web.xml I have defined:

      <context-param>
      <param-name>webSiteId</param-name>
      <param-value>mytenant-WebStore</param-value>
      <description>A unique ID used to look up the WebSite entity</description>
      </context-param>
      <context-param>
      <param-name>localDispatcherName</param-name>
      <param-value>mytenant-ecommerce</param-value>
      <description>A unique name used to identify/recognize the local dispatcher for the Service Engine</description>
      </context-param>
      <context-param>
      <param-name>entityDelegatorName</param-name>
      <param-value>default#mytenant</param-value>
      <description>The Name of the Entity Delegator to use, defined in entityengine.xml</description>
      </context-param>

      Everything works fine. All tenant specific aspects (data and screen)s as it should. Including registering and login. But when I log out, the redirect (to main) doesn't return to the main screen of the (tenant-specific) ecommerce application. In stead it shows the message that the webstore hasn't been set up (A Product Store has not been defined for this ecommerce site. A Product Store can be created using the ofbizsetup wizard.)

      When looking thru the logs I see - prior to the logout event - that the delegator and dispatcher are as defined in the web.xml file for the component, being 'default#mytenant' and 'mytenant-ecommere' (see above exerpt of the web.xml)
      During the logout event, I see the destruction of the existing session and the creation of a new event. See exerpt of log below.

      [java] 2013-12-27 13:15:57,107 (http-bio-0.0.0.0-8443-exec-155) [ControlEventListener.java:107:INFO ] Destroying session: 7AE24FD4BB7547E7463A0C9762ABA2FC.jvm1
      [java] 2013-12-27 13:15:57,108 (http-bio-0.0.0.0-8443-exec-155) [ControlEventListener.java:65 :INFO ] Creating session: AB4989D49CFA17454B62CA75523410B4.jvm1

      Subsequently I see that the delegator has changed to 'default'
      And following appears in the log:
      [java] 2013-12-27 13:15:57,827 (http-bio-0.0.0.0-8080-exec-98) [ RequestHandler.java:349:INFO ] This is the first request in this visit. sessionId=AB4989D49CFA17454B62CA75523410B4.jvm1
      [java] 2013-12-27 13:15:57,828 (http-bio-0.0.0.0-8080-exec-98) [ ProductStoreWorker.java:107:ERROR] No product store found in request, cannot set locale!
      [java] 2013-12-27 13:15:57,828 (http-bio-0.0.0.0-8080-exec-98) [ ProductStoreWorker.java:96 :ERROR] No product store found in request, cannot set CurrencyUomId!

        Issue Links

          Activity

          toashishvijay Ashish Vijaywargiya added a comment -

          Due to recent changes in tenant functionality we are unable to reproduce this issue. Thanks Pierre for creating the issue.

          pfm.smits Pierre Smits added a comment -

          Reopening due to issue OFBIZ-5898 and OFBIZ-5986.

          toashishvijay Ashish Vijaywargiya added a comment -

          We have provided additional comments on Dev mailing list. So now we are closing this issue assuming that we doesn't have any concerns here.


            People

            • Assignee:
              toashishvijay Ashish Vijaywargiya
              Reporter:
              pfm.smits Pierre Smits
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development

                  Agile