Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-5419

Ordering a License product sometimes (most often) gives a blank page

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Release Branch 11.04, Release Branch 12.04, Release Branch 13.07, Trunk
    • Fix Version/s: 14.12.01, 12.04.06, 13.07.02, 16.11.01
    • Component/s: ecommerce
    • Labels:
      None
    • Sprint:
      Bug Crush Event - 21/2/2015

      Description

      The R10.04 version is also affected.

      Sometimes you can order a License product, sometimes not (blank page in any version, tested on official demos).

      And if you hit F5 in the blank page, you order another one and it works (not a blank page, cart with 2 ordered products)

      Could be related to
      <response name="success" type="view-last" value="showcart" save-last-view="true"/>

      1. OFBIZ-5419.patch
        0.8 kB
        Arun Patidar

        Activity

        arunpati Arun Patidar added a comment -

        Hi Jacques,

        Steps to generate issue are not enough clear. Please provide some more additional details to regenerate the issue. Currently I am unable to reproduce the issue at my end.

        jacques.le.roux Jacques Le Roux added a comment - - edited
        1. Get to http://demo-trunk-ofbiz.apache.org/ecommerce/open-gismo-GZ-1006-p
        2. Choose a license type
        3. Click "Add to Cart"

        Result is a blank page, though the product is added to the cart. I see nothing special in log.

        arunpati Arun Patidar added a comment -

        Attached is the patch to fix the same issue. Issue was due to save-current-view value is set to true. This was causing issue in ajax request.

        jacques.le.roux Jacques Le Roux added a comment - - edited

        Thanks Ashish, Arun,

        Arun your patch is in
        trunk r1661287
        R14.12 r1661288
        R13.07 r1661291
        R12.04 r1661298


          People

          • Assignee:
            toashishvijay Ashish Vijaywargiya
            Reporter:
            jacques.le.roux Jacques Le Roux
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development

                Agile