Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-5321

Facility main screen relies on demo data

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: Release Branch 11.04, Release Branch 12.04, Release Branch 13.07, Trunk
    • Fix Version/s: Upcoming Release
    • Component/s: product
    • Labels:
      None
    • Sprint:
      Bug Crush Event - 21/2/2015

      Description

      In facility you are normally supposed to choose a facility on main page. Because the POS component was removed in 13.07 it had a small side effect. You can't anymore choose one facility. Because there is only one so you get directly to the update page of the web facility, which is confusing. Moreover, to see the Report menu (and maybe others) you need to "update" (no changes) the facility.

      The Facility main screen was not designed to support a system with just one facility defined and the issue is now evident in 13.07 because the demo facility defined in the POS component (facilityId="MyRetailStore") is no more loaded. We should not rely on demo data for the proper functioning of the system.

        Activity

        jacques.le.roux Jacques Le Roux added a comment -

        It's maybe related to http://svn.apache.org/viewvc?view=revision&revision=734037 but could be an older issue

        adrianc@hlmksw.com Adrian Crum added a comment -

        Revision 734037 was a bad idea. That is not the de-facto pattern OFBiz uses, and putting that pattern in only one screen is confusing.

        jacopoc Jacopo Cappellato added a comment -

        I agree with Adrian; we can probably fix this issue by reverting the commit that Jacques mentioned.

        jacques.le.roux Jacques Le Roux added a comment -

        Unfortunately there have beeen general changes since then on concerned files. I don't think reverting will be enough.

        jacques.le.roux Jacques Le Roux added a comment -

        A pragmatic workaround for now is to use /facility/control/EditFacility

        pfm.smits Pierre Smits added a comment -

        Maybe this ticket should be closed?

        jacques.le.roux Jacques Le Roux added a comment -

        Before, I'll add a simple sentence to explain that when there is only one facility the search is not avaible, not very smart but at least pragmatic.

        jacques.le.roux Jacques Le Roux added a comment -

        Slightly improved with revision: 1812888


          People

          • Assignee:
            jacques.le.roux Jacques Le Roux
            Reporter:
            jacques.le.roux Jacques Le Roux
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development

                Agile