OFBiz
  1. OFBiz
  2. OFBIZ-5193

Updating EFT Account address resurrects out-of-date EFT Accounts

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: Release Branch 11.04
    • Fix Version/s: SVN trunk
    • Component/s: party
    • Labels:
      None

      Description

      When you update the address that an EFT Acccount is linked to, all expired EFT accounts are "resurrected", which can mean multiple out-of-date copies of an EFT account are displayed in the Payment Method Information.

      To reproduce (with OFBiz demo data):

      • Go to DemoSupplier profile page and click Create EFT Account
      • Enter details of a new account, making sure the account is linked to the DemoSupplier postal address.
      • Click Save and then click Cancel/Done.
      • Back on the profile page, Update for this new EFT account.
      • Change at least one field of the account.
      • Click Save (now there are two EFT account records in the database; one of which is expired). Click Cancel/Done.
      • Now click Update for the DemoSupplier's postal address.
      • Update at least one field. Click Save.
      • Go back to the DemoSupplier profile page. You should see that the old expired EFT accounts are listed in the Payment Method Information.

        Activity

        Jacques Le Roux added a comment -

        Backported in
        R13.07 r1533733
        R12.04 r1533735
        R11.04 r1533734

        Jacques Le Roux added a comment -

        Thanks Karl,

        Your modified and applied patch is in trunk at revision: 1527254

        I applied changes by hand because the patch did not work. I also removed the useless line setting a now var.

        I will backport to releases after OFBIZ-4794

        Jacques Le Roux added a comment -

        You might need to update (we patch on branches not released package)

        Jacques Le Roux added a comment -

        Sorry Karl,

        But it does not work, even in R11.04:

        D:\workspace\release11.04>patch -N -p0 0<eft_account.diff
        patching file applications/accounting/script/org/ofbiz/accounting/payment/PaymentMethodServices.xml
        Hunk #2 FAILED at 64.
        1 out of 2 hunks FAILED – saving rejects to file applications/accounting/script/org/ofbiz/accounting/payment/PaymentMethodServices.xml.rej

        Karl Beecher added a comment -

        Thanks!

        Christian Geisert added a comment -

        git show --no-prefix $HASH

        Karl Beecher added a comment -

        Hi Jacques,

        Thanks for the response. I'm not sure if I'm able to send a patch. We develop using Git and the OFBiz Git mirror, and so we're unable to produce a SVN-formatted patch file.

        Is there are way around this problem?

        Thanks.

        Jacques Le Roux added a comment -

        Hi Karl,

        Please use More Actions/Attach Files to send a patch, thanks!

        For more see Contributors Best Practices

        Karl Beecher added a comment -

        We avoid this bug by altering PaymentMethodServices.xml#setPaymentMethodAddress, so that out-of-date EFT Accounts are filtered out.

        I can provide a patch, but I'm new to JIRA and not sure how to upload it.


          People

          • Assignee:
            Jacques Le Roux
            Reporter:
            Karl Beecher
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development