Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-5052

null [null] on the field phaseName of form hoursNotYetBilled?

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: Release Branch 12.04
    • Fix Version/s: Release Branch 12.04, 16.11.01
    • Component/s: projectmgr
    • Labels:
      None
    • Sprint:
      Bug Crush Event - 21/2/2015

      Description

      Using "Release-revision : release12.04-1388834" demo data DemoEmployee2 completed their timesheet. Admin went to Billing on that project and got this error

      org.ofbiz.widget.screen.ScreenRenderException: Error rendering screen component://common/widget/CommonScreens.xml#GlobalDecorator: java.lang.IllegalArgumentException: Return value from use-when condition eval was not a Boolean: null [null] on the field phaseName of form hoursNotYetBilled (Return value from use-when condition eval was not a Boolean: null [null] on the field phaseName of form hoursNotYetBilled)

      at https://localhost:8443/projectmgr/control/projectBilling?projectId=9000

      I found specialpurpose/projectmgr/widget/form/ProjectForms.xml contains

      <field name="phaseName" position="1" use-when="showPosition1"><display description="$

      {phaseName}[${phaseId}]"/></field>

      and changed it to

      <field name="phaseName" position="1" use-when="showPosition1!=null"><display description="${phaseName}

      [$

      {phaseId}]"/></field>

      but https://localhost:8443/projectmgr/control/projectBilling?projectId=9000 now gives me

      org.ofbiz.widget.screen.ScreenRenderException: Error rendering screen component://common/widget/CommonScreens.xml#GlobalDecorator: java.lang.IllegalArgumentException: Return value from use-when condition eval was not a Boolean: null [null] on the field workEffortName of form hoursNotYetBilled (Return value from use-when condition eval was not a Boolean: null [null] on the field workEffortName of form hoursNotYetBilled)

      It appears to me that I've created a data error and I'm unsure what to do to correct the error.

      Since it's now Monday DemoEmployee2 has a new timesheet and has started entering hours, but; Admin still gets the same error at Billing.

      I can avoid the error by commenting phaseName and workEffortName in ProjectForms.xml

      <!--

      <field name="phaseName" position="1" use-when="showPosition1"><display description="${phaseName}[${phaseId}

      ]"/></field>

      <field name="workEffortName" title="$

      {uiLabelMap.FormFieldTitle_taskName}

      " position="1" use-when="showPosition1"><hyperlink target="taskView?workEffortId=$

      {workEffortId}" description="${workEffortName}[${workEffortId}

      ]"/></field>

      -->

      Thanks for your help with this issue,
      DaleEMoore@gMail.Com

        Activity

        pfm.smits Pierre Smits added a comment -

        I will check if the issue still exists in trunk.

        gil portenseigne Gil Portenseigne added a comment -

        I just try to reproduce the problem without success, in trunk and 12.04 branch with only demo data. I guess it can be closed.

        jacques.le.roux Jacques Le Roux added a comment - - edited

        Thanks Gil, I close if someone still sees the problem please reopen


          People

          • Assignee:
            jacques.le.roux Jacques Le Roux
            Reporter:
            daleemoore Dale E. Moore
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development

                Agile