Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: Release Branch 10.04, Release 10.04, Release Branch 11.04, SVN trunk, Release 11.04.01, Release Branch 12.04
    • Component/s: None
    • Labels:
      None

      Description

      Help OFBiz Help-day 2012 is the first annual moment dedicated to fix the help documents for end users, so that the help documents reflect the changes that have been made during the year to the code regarding screens and forms.

      This is the umbrella Issue for all bugfixes regarding help files in the helpdata folder of each application/component exposed to end users and the assocated <webappname>HelpData.xml file.

        Issue Links

          Activity

          Tom Burns added a comment -

          This umbrella issue is also a good place to discuss and collect best practices for writing OFBiz help documentation. This could include comments on appropriate content, presentation and style. These topics are common across applications.

          Tom Burns added a comment -

          Takeaway from comments by Has and Jacques in the thread "Help OFBiz Help - day" discussing field definitions in the help doc.

          Fields defined in help documentation should be based on the field definitions from the Entitymodel.xml <description> tag and the applications EntityLabels.xml file.

          If the definition is new then create the appropriate entries in Entitymodel.xml and EntityLabels.xml files. This will give authority to the help definition and insure consistency.

          Adrian Crum added a comment -

          Just a reminder that this is 2012, not 2011.

          Pierre Smits added a comment -

          Thanks for the correction, Adrian.

          Pierre Smits added a comment -

          Tom,

          Can you upload your enhanced help files for the Human Resources application in the linked sub task for humanres as a patch?

          Regards,

          Pierre

          Tom Burns added a comment -

          Pierre,

          I've started adding content to the stubs so they are not in a complete as a set at the moment. I'm going to be on other things for the next two days. I'll begin uploading pages some time early next week.

          Tom

          Jacques Le Roux added a comment -

          PLease Tom, create a subtask of OFBIZ-2219 for HumanRes. I forgot we had already this umbrella task.

          Duplicate of OFBIZ-2219


            People

            • Assignee:
              Unassigned
              Reporter:
              Pierre Smits
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development