OFBiz
  1. OFBiz
  2. OFBIZ-4853

Project resource overview doesn't show the resources with a thru-date before the current date.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: Release 10.04, Release 11.04.01, Release Branch 11.04, Trunk
    • Fix Version/s: Trunk
    • Labels:
      None

      Description

      When a project manager expires the assignment of a resource by clicking the delete button in the Project Resources overview the resource is deleted from the overview. It should be that the resource is still shown in the overview with the tru-date visible.

      Otherwise there will be a discrepancy between the overview of resources of the project and the project dashboard.

      The name of the button is also wrong. It should state 'expire' not 'delete'.

        Activity

        Pierre Smits created issue -
        Pierre Smits added a comment -

        This patch fixes the bug.

        Pierre Smits made changes -
        Field Original Value New Value
        Attachment OFBIZ-4853-project-resources.patch [ 12525731 ]
        Pierre Smits made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Jacques Le Roux added a comment -

        Thanks Pierre,

        Your patch is in trunk at r1338695. Only in trunk because this was not a bug but an improvement.

        As you suggested, I have also created and used a new label FormFieldTitle_expireButton copying labels from CommonExpire.

        Jacques Le Roux made changes -
        Fix Version/s Release 11.04.01 [ 12320772 ]
        Resolution Fixed [ 1 ]
        Status Patch Available [ 10002 ] Closed [ 6 ]
        Assignee Jacques Le Roux [ jacques.le.roux ]
        Fix Version/s Release Branch 10.04 [ 12314832 ]
        Fix Version/s Release Branch 11.04 [ 12316420 ]
        Fix Version/s Release 10.04 [ 12316421 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        2m 43s 1 Pierre Smits 05/May/12 16:39
        Patch Available Patch Available Closed Closed
        10d 1h 33m 1 Jacques Le Roux 15/May/12 18:13

          People

          • Assignee:
            Jacques Le Roux
            Reporter:
            Pierre Smits
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 0.5h
              0.5h
              Remaining:
              Remaining Estimate - 0.5h
              0.5h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development