OFBiz
  1. OFBiz
  2. OFBIZ-2398 BizznessTime Theme
  3. OFBIZ-3061

You don't to distinguish between normal text and URL links in screens

    Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      For instance look at the paiment links in a sales invoice, it's the same as normal text. Before the color let you find them easily and even know that there are there if you don't know much OFBiz

      1. Payments links in a sale invoice.jpg
        93 kB
        Jacques Le Roux
      2. link.patch
        0.5 kB
        Bilgin Ibryam

        Activity

        Jacques Le Roux added a comment -

        You can't see they are links at 1st glance. Not good for newbies

        Bilgin Ibryam added a comment -

        You can't see the links even in second glance I wonder how people use this theme w/o being able to make a distinction between a text and a link?

        I propose to underline all links belonging to .basic-table except for the buttons in themes\bizznesstime\webapp\bizznesstime\css\style.css by adding this:

        .basic-table td a

        { text-decoration: underline; }

        .basic-table td a.buttontext

        { text-decoration: none; }

        If there are no other proposals I will commit this soon.

        Bilgin

        Jacques Le Roux added a comment -

        Hi Bilgin,

        I think it's time to commit, at least we will see something, I was trapped another time

        Thanks

        Bilgin Ibryam added a comment -

        Thanks for the reminder Jacques.

        Committed to trunk in r831159.

        Jacques Le Roux added a comment -

        Hi Bilgin,

        I agree it's better than before, but I wonder now if we should not only color the link in tables. Because, for instance, underline all buttons is ugly.

        Jacques Le Roux added a comment -

        Mmm, I spoke to fast

        I suppose this snippet

        +.basic-table td a.buttontext

        { + text-decoration: none; +}

        Was intended for that, now I wonde why it does not work...

        Jacques Le Roux added a comment -

        Look for parties search results for instance

        Bilgin Ibryam added a comment -

        Jacques,

        you are right, colored links would look better .
        The above code doesn't work in parties search result because it is ftl and use different css classes for buttons
        Now I think we should go simpler, by coloring all the links.
        Could you try the attached path and tell your opinion?

        Jacques Le Roux added a comment -

        Thanks Bilgin,

        Yes it looks better, I have commited your patch in trunk at r831238 .
        I have also decided to backport this change to R9.04 at r831241 because I believe Bizness Time is barely usable without it


          People

          • Assignee:
            Bilgin Ibryam
            Reporter:
            Jacques Le Roux
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development