Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-1525 Issue to group security concerns
  3. OFBIZ-12812

[SECURITY] Remove deprecated Apache XML-RPC related code (CVE-2023-49070)

Attach filesAttach ScreenshotVotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Sub-task
    • Status: Closed
    • Major
    • Resolution: Fixed
    • Upcoming Branch
    • Upcoming Branch
    • framework/service
    • None
    • Bug Crush Event - 21/2/2015

    Description

      Apache XML-RPC is no longer maintained[1], we should remove the xml rpc related code from trunk.

      [1] https://github.com/advisories/GHSA-6vwp-35w3-xph8

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            deepak Deepak Dixit
            deepak Deepak Dixit
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Agile

                Completed Sprint:
                Bug Crush Event - 21/2/2015 ended 26/Feb/15
                View on Board

                Slack

                  Issue deployment