Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-11149

In Product Image Management uploading file fails due to missing createContentAssoc.contentIdTo

Agile BoardAttach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Invalid
    • Trunk
    • None
    • content, product
    • None

    Description

      The error is

      2019-08-07 14:48:09,006 |jsse-nio-8443-exec-3 |ImageManagementServices       |E| null
      org.apache.ofbiz.service.ServiceValidationException: The following required parameter is missing: [createContentAssoc.contentIdTo]
              at org.apache.ofbiz.service.ModelService.validate(ModelService.java:581) ~[ofbiz.jar:?]
              at org.apache.ofbiz.service.ServiceDispatcher.runSync(ServiceDispatcher.java:395) ~[ofbiz.jar:?]
              at org.apache.ofbiz.service.ServiceDispatcher.runSync(ServiceDispatcher.java:240) ~[ofbiz.jar:?]
              at org.apache.ofbiz.service.GenericDispatcherFactory$GenericDispatcher.runSync(GenericDispatcherFactory.java:88) ~[ofbiz.jar:?]
              at org.apache.ofbiz.product.imagemanagement.ImageManagementServices.addMultipleuploadForProduct(ImageManagementServices.java:220) [ofbiz.jar:?]
      

      R18, and I guess below, works

      Attachments

        Issue Links

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            jleroux Jacques Le Roux
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment