Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-10615

Content - Able to add empty Forum Group

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 16.11.05
    • Fix Version/s: 17.12.01, 16.11.06
    • Component/s: content
    • Labels:
      None

      Description

      Steps to Regenerate issue:

      1. Login to demo-trunk or demo-stable instance with details:

      URL - https://demo-trunk.ofbiz.apache.org/content/control/findForumGroups 

      admin/ ofbiz  OR

      URl - https://demo-stable.ofbiz.apache.org/content/control/createForumGroup

      admin/ ofbiz

      1. Go to Content > Forum and try to create new forum group.
      2. do not enter Forum Group Name and Description.
      3. Click on the Submit button.

      Actual - System allowed the user to enter an empty forum group. Please refer attached snapshots. This issue is occurring at demo-trunk and demo-stable instance. 

      Expected - Empty Forum group should not be added and if the user tries to do this..He should not be allowed and proper validation error message should display.

        Attachments

        1. ForumGroupDemoNotWorkingCorrect.png
          262 kB
          Sanjay Yadav
        2. ForumGroupStableNotWorkingCorrect.png
          242 kB
          Sanjay Yadav
        3. OFBIZ-10615.patch
          0.9 kB
          Anushi Gupta

          Activity

            People

            • Assignee:
              jleroux Jacques Le Roux
              Reporter:
              sanjay.yadav@hotwaxsystems.com Sanjay Yadav
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: