Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-10455

Put back the com.lowagie:itext license from 4.2.0 to 2.1.7

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: Trunk, 17.12.01
    • Fix Version/s: 17.12.01
    • Component/s: content
    • Labels:
      None

      Description

      At r1812161 for OFBIZ-9674 we updated com.lowagie:itext license from 2.1.7 to 4.2.0. Scott mentionned at https://s.apache.org/ixHW:

      I just noticed that the iText maven bundle is a bit tricksy and includes iText 5.6.6 as a dependency, with the latter being GPL licensed.

      Actually Scott meant itextpdf (was clear in his message), and It turned out that not only itextpdf was a problem but the 4.2.0 version in its entirety as discovered in the thread.

      The solution is to get back to the 2.1.7 version which is still MPL licensed.

      I must note here that for the same reason the BIRT runtime that we use in OFBiz, and all BIRT runtime versions, are using the 2.1.7 version. There is more information on why in the thread mentionned above if needed.

        Attachments

          Activity

            People

            • Assignee:
              jleroux Jacques Le Roux
              Reporter:
              jleroux Jacques Le Roux
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: