Details

    • Type: Sub-task Sub-task
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-beta2
    • Fix Version/s: 2.0-beta3
    • Component/s: Build System
    • Labels:
      None

      Description

      axis2-war module's testing part is failed.

      1. buildr_test.log
        65 kB
        David McLure
      2. buildr.log
        302 kB
        David McLure

        Activity

        Jeff Yu created issue -
        David McLure added a comment -

        I am seeing the same thing, but I am curious as to how the original version 2.0 Beta2 was ever built then? I am wondering if maybe there are differences in the software versions I am using to run buildr. I am attempting to build ODE v2.0 beta2 on Windows XP using jruby (as opposed to ruby - since it seems you can't get a relatively recent working version of ruby for the Windows platform these days), all with Java version 1.5.0_15.

        Because I am using jruby, I also use the following commands (buildr.log and buildr_test.log output files are attached) :

        jruby -S buildr package test=no > buildr.log 2>&1

        jruby -S buildr test > buildr_test.log 2>&1

        I'd be interested to know what platform(s) are being successfully used for running buildr to build ODE.

        Thanks

        David McLure

        p.s. The error can be found at the end of the buildr_test.log

        David McLure made changes -
        Field Original Value New Value
        Attachment buildr.log [ 12437773 ]
        Attachment buildr_test.log [ 12437774 ]
        Jeff Yu added a comment -

        Hi David,

        Sorry, this issue is for the 2.0 maven build, it is not the buidlr build.

        Could you please ask this question in the user maillist. I believed that both Windows and Linux should been run successfully with the buildr build.

        Regards
        Jeff

        David McLure added a comment - - edited

        Hi Jeff,

        Actually, the problem I reported here is the axis2-war test failure in the "buildr test" step after what appeared to be a successful build (see the buildr_test.log output I attached).

        Thanks

        Dave

        Tammo van Lessen added a comment -

        I can't reproduce this with most recent trunk. I assume this has been fixed with the upgrade to Buildr 1.4.x and several build tweaks.

        Tammo van Lessen made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            Jeff Yu
          • Votes:
            3 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development