ODE
  1. ODE
  2. ODE-244

Potential NPE in MessageExchangeDAOImpl

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.1
    • Fix Version/s: 1.2
    • Component/s: BPEL Runtime
    • Labels:
      None

      Description

      As reported on the mailing list,
      http://www.nabble.com/Async-Error-tc15802255.html

      ERROR - BpelEngineImpl - Scheduled job failed; jobDetail=

      {ckey=-1~hqejbhcnphr334wev5cdp2, correlatorId=16.echoResp, inmem=false, iid=3287, type=MATCHER}

      java.lang.NullPointerException
      at org.apache.ode.dao.jpa.MessageExchangeDAOImpl.getCorrelationKeys(MessageExchangeDAOImpl.java:320)
      at org.apache.ode.dao.jpa.CorrelatorDAOImpl.dequeueMessage(CorrelatorDAOImpl.java:74)
      at org.apache.ode.bpel.engine.BpelRuntimeContextImpl.matcherEvent(BpelRuntimeContextImpl.java:1316)
      at org.apache.ode.bpel.engine.BpelProcess.handleWorkEvent(BpelProcess.java:342)
      at org.apache.ode.bpel.engine.BpelEngineImpl.onScheduledJob(BpelEngineImpl.java:318)
      at org.apache.ode.bpel.engine.BpelServerImpl.onScheduledJob(BpelServerImpl.java:364)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4$1.call(SimpleScheduler.java:335)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4$1.call(SimpleScheduler.java:334)
      at org.apache.ode.scheduler.simple.SimpleScheduler.execTransaction(SimpleScheduler.java:173)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4.call(SimpleScheduler.java:333)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4.call(SimpleScheduler.java:330)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
      at java.lang.Thread.run(Thread.java:619)
      ERROR - SimpleScheduler - Error while executing transaction
      org.apache.ode.bpel.iapi.Scheduler$JobProcessorException: java.lang.NullPointerException
      at org.apache.ode.bpel.engine.BpelEngineImpl.onScheduledJob(BpelEngineImpl.java:328)
      at org.apache.ode.bpel.engine.BpelServerImpl.onScheduledJob(BpelServerImpl.java:364)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4$1.call(SimpleScheduler.java:335)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4$1.call(SimpleScheduler.java:334)
      at org.apache.ode.scheduler.simple.SimpleScheduler.execTransaction(SimpleScheduler.java:173)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4.call(SimpleScheduler.java:333)
      at org.apache.ode.scheduler.simple.SimpleScheduler$4.call(SimpleScheduler.java:330)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.NullPointerException
      at org.apache.ode.dao.jpa.MessageExchangeDAOImpl.getCorrelationKeys(MessageExchangeDAOImpl.java:320)
      at org.apache.ode.dao.jpa.CorrelatorDAOImpl.dequeueMessage(CorrelatorDAOImpl.java:74)
      at org.apache.ode.bpel.engine.BpelRuntimeContextImpl.matcherEvent(BpelRuntimeContextImpl.java:1316)
      at org.apache.ode.bpel.engine.BpelProcess.handleWorkEvent(BpelProcess.java:342)
      at org.apache.ode.bpel.engine.BpelEngineImpl.onScheduledJob(BpelEngineImpl.java:318)
      ... 11 more

        Activity

        Alex Boisvert added a comment -

        Fixed in ode-1.1 branch,
        Sending dao-jpa/src/main/java/org/apache/ode/dao/jpa/MessageExchangeDAOImpl.java
        Transmitting file data .
        Committed revision 633264.

        and ode-trunk,
        Sending dao-jpa/src/main/java/org/apache/ode/dao/jpa/MessageExchangeDAOImpl.java
        Transmitting file data .
        Committed revision 633265.


          People

          • Assignee:
            Alex Boisvert
            Reporter:
            Alex Boisvert
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development