Uploaded image for project: 'Jackrabbit Oak'
  1. Jackrabbit Oak
  2. OAK-6941

Compatibility matrix for oak-run compact

    XMLWordPrintableJSON

    Details

      Description

      Problem statement

      For compacting the segmentstore using oak-run, the safest option is to use the same version of oak-run as the Oak version used to generate the repository. Yet, sometimes, a newer oak-run version is recommended to benefit of bug fixes and improvements, but not every combination of source repo and oak-run is safe to use and the user needs a way to check the compatibility. Thus, the users need a tool that guides the decision of which version to use.

      Requirements

      • Easy to decide what oak-run version should be used for a certain Oak version
      • Up to date with the latest releases
      • Machine readable for scripting
      • Include details on the benefits of using a certain version (release notes)
      • Blacklist of versions that should not be used (with alternatives)

      Solution

      TBD

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              volteanu Valentin Olteanu
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated: