Uploaded image for project: 'Jackrabbit Oak'
  1. Jackrabbit Oak
  2. OAK-5455

Specify versions for maven plugins used in build for ensuring stable builds

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.7.14, 1.8.0, 1.4.25, 1.6.18
    • Component/s: parent
    • Labels:
      None

      Description

      Running a check for plugin versions used in oak build

      mvn versions:display-plugin-updates
      

      leads to following warning

      [INFO] The following plugin updates are available:
      [INFO]   org.apache.felix:maven-scr-plugin .................. 1.16.0 -> 1.21.0
      [INFO] 
      [WARNING] The following plugins do not have their version specified:
      [WARNING]   maven-compiler-plugin ...................................... 2.0.2
      [WARNING]   maven-deploy-plugin ......................... (from super-pom) 2.4
      [WARNING]   maven-failsafe-plugin ..................................... 2.12.4
      [WARNING]   maven-jar-plugin ............................................. 2.1
      [WARNING]   maven-javadoc-plugin ......................................... 2.0
      [WARNING]   maven-release-plugin ................. (from super-pom) 2.0-beta-4
      [WARNING]   maven-resources-plugin ....................................... 2.2
      [WARNING]   maven-surefire-plugin ...................................... 2.4.2
      [INFO] 
      [WARNING] Project does not define minimum Maven version, default is: 2.0
      [INFO] Plugins require minimum Maven version of: 3.0.5
      [INFO] Note: the super-pom from Maven 3.3.9 defines some of the plugin
      [INFO]       versions and may be influencing the plugins required minimum Maven
      [INFO]       version.
      [INFO] 
      [ERROR] Project does not define required minimum version of Maven.
      [ERROR] Update the pom.xml to contain
      [ERROR]     <prerequisites>
      [ERROR]       <maven>3.0.5</maven>
      [ERROR]     </prerequisites>
      

      As a fix we should

      1. Specify version for all maven plugin in use
      2. Specify minimum version of maven to be used (version used in CI is 3.2.1)
      3. Configure enforcer plugin to ensure that in future no plugin is used without specifying the version [1]

      [1] http://maven.apache.org/enforcer/enforcer-rules/requirePluginVersions.html

        Attachments

        1. enforce.diff
          2 kB
          Julian Reschke
        2. OAK-5455-v1.patch
          7 kB
          Chetan Mehrotra

          Issue Links

            Activity

              People

              • Assignee:
                reschke Julian Reschke
                Reporter:
                chetanm Chetan Mehrotra
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: