Description
Currently the MicroKernel API specifies for the method "diff", if the depth parameter is used, that unspecified changes below a certain path can be returned as:
^ "/some/path"
I would prefer the slightly more verbose:
^ "/some/path": {}
Reason: It is similar to how getNode() returns node names if the depth limited: "some":{"path":{}}, and it makes parsing unambiguous: there is always a ':' after the path, whether a property was changed or a node was changed. Without the colon, the parser needs to look ahead to decide whether a node was changed or a property was changed (the token after the path could be the start of the next operation). And we could never ever support ':' as an operation because that would make parsing ambiguous.