Uploaded image for project: 'Nutch'
  1. Nutch
  2. NUTCH-2583

Upgrading Nutch's dependencies

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Implemented
    • Affects Version/s: 1.14
    • Fix Version/s: 1.15
    • Component/s: build
    • Labels:
      None

      Description

      Hi,

       

      It would be nice to be able to upgrade all of Nutch's dependencies to the latest possible available.

      I've attached an Ivy.xml with the latest possible dependencies without breaking the compile. I've tested it with a few runs of the "crawl script", so far it seems to work, it generates, it fetches, it parses, it indexes to Solr..... Increasing any of this dependencies breaks the compile.

       

      PS: I haven't touched any of the Hadoop stuff and don't remember if I touched the testing part or not.

        Attachments

        1. ivy.xml
          8 kB
          Ralf

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Bl4ck1c3 Ralf
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: