Uploaded image for project: 'Nutch'
  1. Nutch
  2. NUTCH-2380

indexer-elastic version upgrade to 5.3.0

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.13
    • Fix Version/s: 1.14
    • Component/s: indexer
    • Labels:
      None
    • Patch Info:
      Patch Available
    • Flags:
      Patch

      Description

      The current version of the indexer-elastic plugin is not compatible with ES 5.x. The patch bumps the ES lib version to 5.3 but also requires a Nutch classloader fix (NUTCH-2378) due to runtime dependency issues.

      I didn't test compatibility with ES 2.x, so not sure if that still works.

      Please let me know what you think of the provided patch.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jurian Jurian Broertjes
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: