Uploaded image for project: 'Nutch'
  1. Nutch
  2. NUTCH-1920

Upgrade Nutch to use Java 1.7

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3, 1.10
    • Fix Version/s: 1.10, 2.3.1
    • Component/s: build
    • Labels:
      None

      Description

      In order to build the Nutch Javadoc securely, we rely upon no less than Java version 7u25 or greater. See NUTCH-1590.
      indexer-elastic also requires a JDK 1.7 in order compile.
      We should make the upgrade and state support for Java 1.7 based on the following announcement from Oracle

      End of Public Updates for Oracle JDK 7
      
      The April 2015 CPU release will be the last Oracle JDK 7 publicly available update. For more information, and details on how to receive longer term support for Oracle JDK 7, please see the Oracle Java SE Support Roadmap. 
      

        Attachments

        1. NUTCH-1920-trunk.patch
          1.0 kB
          Lewis John McGibbney

          Activity

            People

            • Assignee:
              lewismc Lewis John McGibbney
              Reporter:
              lewismc Lewis John McGibbney
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: