Uploaded image for project: 'Apache NiFi'
  1. Apache NiFi
  2. NIFI-7143

Upgrade GCP dependency

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.10.0, 1.11.0, 1.11.1
    • Fix Version/s: 1.12.0, 1.11.3
    • Component/s: None
    • Labels:
      None

      Description

      PubSub via proxy does not work due to a bug in the grpc lib mentioned here. It affects grpc versions 1.22.0 and 1.23.0.
      Upgrade the GCP dependency to a newer version that uses 1.24.0+ grpc for PubSub.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                turcsanyip Peter Turcsanyi
                Reporter:
                turcsanyip Peter Turcsanyi
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 40m
                  40m