Uploaded image for project: 'Apache NiFi'
  1. Apache NiFi
  2. NIFI-2448

Hive Processors depend on too recent a Hive version

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: 1.0.0
    • Fix Version/s: None
    • Component/s: Extensions
    • Labels:
      None

      Description

      The new Hive bundle depends on version 2.0.0 of Hive. This means that it can only connect to very recent Hive distributions.

      Sadly very few people in the field have upgraded their Hive to the latest and greatest, and as per https://issues.apache.org/jira/browse/HIVE-6050 the issue of backward compatibility in the client is still not resolved.

      We should look at lowering the dependency version to allow connections with older Hive distros.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                simonellistonball Simon Elliston Ball
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: