Uploaded image for project: 'Apache NiFi'
  1. Apache NiFi
  2. NIFI-10029

Must declare the scalar variable @P7UpdateKey Error

Agile BoardAttach filesAttach ScreenshotAdd voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Open
    • Major
    • Resolution: Unresolved
    • 1.16.0
    • None
    • Core Framework

    Description

      When I wanted to update the database with PutDatabaseRecord in Apache nifi 1.16.0 I got the below error:

      Routing to failure.: Must declare the scalar variable "@P7UpdateKey".{}

      {{}}

      Note: this error occurred when updating data in the SQL Server

      But there is no problem when inserted into the database.

      I think there was such a problem when I updated to version 1.16.0. But I'm not sure about that.

      Production environment working with version 1.15.3 fine.

      https://stackoverflow.com/questions/72171106/apache-nifi-must-declare-the-scalar-variable-p7updatekey-error

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            khedri MohammadReza Khedri

            Dates

              Created:
              Updated:

              Slack

                Issue deployment