Uploaded image for project: 'NetBeans'
  1. NetBeans
  2. NETBEANS-1759

After migrating to NetBeans 9 it is unable to find the SVN client

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 9.0
    • Fix Version/s: 9.0
    • Labels:
      None
    • Environment:

      Description

      Note: for the previous NetBeans 8.2 there exists checked out project from a subversion repository. As version control plugin SvnKit is used (org.netbeans.libs.svnClientAdapter.svnkit/1 [1.24.1 201609300101]).

      • fresh download and installation of NetBeans 9. Used the script of Carl J. Mosca from github (https://github.com/carljmosca/netbeans-macos-bundle, install.sh)
      • start NetBeans 9.
      • requires to migrated the configuration from 8.2 to 9, which I did:
        xxx@xxx:~$ ls -l ~/Library/Application\ Support/NetBeans/
        total 7824
        drwxr-xr-x 15 walla 3536 480 Nov 28 09:52 8.2
        drwxr-xr-x 8 walla 3536 256 Nov 28 10:27 9.0
      • then a window pops up and asks to install the nb-javac library which is highly recommended by the NetBeans team. So, library installed.
      • after a restart NetBeans found in the previous version plugins which can be imported to NetBeans 9. One module is Subversion remote plugin org.netbeans.modules.subversion.remote. All of the previous plugins are imported to version 9, including the Subversion remote plugin.
      • after a second restart NetBeans 9 claims in the IDE log file about subversion mismatches: 

      INFO [org.netbeans.libs.svnclientadapter]: Javahl client adapter is not available
      Failed to load JavaHL Library.
      These are the errors that were encountered:
      no libsvnjavahl-1 in java.library.path
      no svnjavahl-1 in java.library.path
      no svnjavahl in java.library.path
      ...
      INFO [org.netbeans.modules.subversion.client.SvnClientFactory]: JavaHL not available. Falling back on SvnKit.
      INFO [org.netbeans.modules.subversion.client.SvnClientFactory]: SvnKit not available. Falling back on commandline.
      INFO [org.netbeans.modules.subversion]: Commandline client version: 1.10.0 (r1827917)
      WARNING [org.netbeans.modules.subversion]: Unsupported svn version. You need >= 1.5
      WARNING [org.netbeans.modules.subversion.client.SvnClientFactory]: executable binary path set to /usr/bin yet client not available.

      • on my drive svn is installed and usable:

      walla@mcsmcwalla:~$ which svn
      /usr/bin/svn
      walla@mcsmcwalla:~$ ls -l $(which svn)
      -rwxr-xr-x 1 root wheel 18288 Jul 4 13:02 /usr/bin/svn
      walla@mcsmcwalla:~$ svn --version
      svn, version 1.10.0 (r1827917)
      compiled Sep 25 2018, 18:25:22 on x86_64-apple-darwin17.0.0
      ...

       

      We can see in the log snippet that the version on my drive is equal to the one which NetBeans found. However, NetBeans claims that the version is incorrect or did not find the client at all. 

      Can somebody comment on this?

      Best regards, Marcus

        Attachments

        1. netbeans_9_ide.log
          70 kB
          Marcus Walla
        2. Screen Shot 2018-11-28 at 12.45.28.png
          52 kB
          Marcus Walla
        3. Screen Shot 2018-11-28 at 12.55.57.png
          121 kB
          Marcus Walla

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              scientific Marcus Walla
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Due:
                Created:
                Updated: