Uploaded image for project: 'Maven WAR Plugin'
  1. Maven WAR Plugin
  2. MWAR-335

Upgrade maven-archiver dependency to v2.6

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.6
    • Component/s: None
    • Labels:
      None
    • Environment:
      n/a

      Description

      Upgrade maven-archiver dependency to v2.6 (latest version currently available as of ticket creation). Also align version of plexus-archiver (v2.8.1).

      Release Notes - Maven Archiver - Version 2.6

        • Bug
      • MSHARED-241 - Use last plexus-archiver version
      • MSHARED-360 - Upgrade plexus-archiver to 2.6.1 (was 2.6) and plexus-utils to 3.0.18 for java7+ symlink support
      • MSHARED-368 - Update plexus-interpolation to 1.21 to avoid potential thread safety issues
        • Improvement
      • MSHARED-224 - Add documentation on the useUniqueVersions to the index page
      • MSHARED-270 - Add Implementation-URL to DefaultImplementationEntries
      • MSHARED-273 - Update documentation for the "Created-By" manifest entry
      • MSHARED-363 - Update version of plexus-archiver to 2.7

        Attachments

          Activity

            People

            • Assignee:
              afloom Anders Hammar
              Reporter:
              afloom Anders Hammar
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: