Details
-
Improvement
-
Status: Closed
-
Minor
-
Resolution: Fixed
-
3.0.0
-
None
Description
Make the naming of the properties consistent to the plugin naming cause currently the properties look like this:
@Parameter( property = "attach", defaultValue = "true" ) @Parameter( property = "source.excludeResources", defaultValue = "false" ) @Parameter( property = "source.includePom", defaultValue = "false" ) @Parameter( property = "source.forceCreation", defaultValue = "false" ) @Parameter( property = "source.skip", defaultValue = "false" ) @Parameter( property = "maven.source.classifier", defaultValue = "sources" ) @Parameter( property = "maven.source.test.classifier", defaultValue = "test-sources" )
So it would be nice to change it to the following:
- attach should be named maven.source.attach,
- source.excludeResources should be named maven.source.excludeResources,
- source.includePom should be named maven.source.includePom,
- source.forceCreation should be named maven.source.forceCreation,
- source.skip should be named maven.source.skip