Maven Site Plugin
  1. Maven Site Plugin
  2. MSITE-30

site:deploy incompatibilities with m1.02

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 2.1
    • Component/s: site:deploy
    • Labels:
      None
    • Environment:
      All

      Description

      Deploying a site in m2 has changed since m1.
      1) m1 used the "tar" and "gunzip" command on the remote site, where m2 uses the "unzip" command. This poses a problem for be since my remote site does not support the "unzip" command, thus making the "priority" of this issue major

      1.1) Their may be desire to deploy without the use of tools like tar and zip on some site. The deploy would esentailly be a recersive copy

      2) No equivelent to m1 property maven.site.chmod.mode. I use this to allow other member is the group update and delete permission

      3) No equivelent to m1 property maven.site.publish.clean

      Their are other properties for the m1.02 not mentioned above, but I suspect the they can be calculated from m2 files, i.e. pom.xml and settings.xml.

      Paul Spencer

        Issue Links

          Activity

          Paul Spencer created issue -
          Jason van Zyl made changes -
          Field Original Value New Value
          Key MNG-1627 MSITE-30
          Project Maven 2 [ 10500 ] Maven 2.x Site Plugin [ 11146 ]
          Type New Feature [ 2 ] Bug [ 1 ]
          Affects Version/s 2.0 [ 11703 ]
          Component/s maven-site-plugin [ 11802 ]
          Workflow Maven [ 42297 ] jira [ 44220 ]
          Brett Porter made changes -
          Fix Version/s 2.0 [ 12151 ]
          Jason van Zyl made changes -
          Workflow jira [ 44220 ] Maven [ 45016 ]
          Brett Porter made changes -
          Workflow Maven [ 45016 ] Maven New [ 52362 ]
          Paul Spencer added a comment -

          Is this in part a WAGGON issue since it is in AbstractWaggon.createZip where the type compression, either ZIP or GZIP, is set?

          A suggestion:
          Allow the plugin/Waggon to determine what is supported on the remote side, (zip, gzip, tar,...) and then use what is available.

          Paul Spencer

          Jason van Zyl made changes -
          Fix Version/s 2.0.1 [ 13092 ]
          Fix Version/s 2.0 [ 12151 ]
          Dennis Lundberg made changes -
          Component/s site:deploy [ 12949 ]
          Maik Ebert added a comment -

          Is there any update about the missing property "maven.site.publish.clean"?

          Dennis Lundberg made changes -
          Fix Version/s 2.0-beta-7 [ 13092 ]
          Fix Version/s 2.0-beta-8 [ 14324 ]
          Dennis Lundberg made changes -
          Issue Type Bug [ 1 ] Improvement [ 4 ]
          Paul Spencer added a comment -

          Dennis,
          I object to this issue be downgraded from a BUG since the desired behavior worked in a prior version of the plugin.

          Although have installed unzip on my HP-UX box to get around the problem #1 of the issue, I continue to have an issues with the chmod command.

          Paul Spencer

          Dennis Lundberg added a comment -

          Paul,
          When you say "a prior version", do you mean it used to work in M1?

          Paul Spencer added a comment -

          Yes.

          Paul Spencer

          Dennis Lundberg added a comment -

          We are talking about a major version upgrade here and all features from a previous version may not there in the new version, especially if it is a major rewrite as it is in this case.

          In my book the definition of a bug is:

          "A feature that is designed to be in the software. When that feature does not work as designed it's a bug."

          That's the reason for me to change the type for this issue.

          Lukas Theussl made changes -
          Link This issue is related to MSITE-339 [ MSITE-339 ]
          Lukas Theussl made changes -
          Link This issue is related to MSITE-380 [ MSITE-380 ]
          Lukas Theussl made changes -
          Link This issue is related to MSITE-141 [ MSITE-141 ]
          Lukas Theussl made changes -
          Link This issue is related to MSITE-330 [ MSITE-330 ]
          Lukas Theussl made changes -
          Link This issue is superceded by MSITE-250 [ MSITE-250 ]
          Lukas Theussl made changes -
          Link This issue is superceded by MSITE-213 [ MSITE-213 ]
          Lukas Theussl made changes -
          Link This issue is related to MSITE-141 [ MSITE-141 ]
          Lukas Theussl made changes -
          Link This issue is superceded by MSITE-141 [ MSITE-141 ]
          Lukas Theussl added a comment -

          1) is tracked by MSITE-213
          2) is fixed with MSITE-141
          3) is tracked in MSITE-250

          Please open new tickets for any specific requests.

          Lukas Theussl made changes -
          Resolution Duplicate [ 3 ]
          Status Open [ 1 ] Closed [ 6 ]
          Assignee Lukas Theussl [ lukas ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 13:16:22 UTC 2015 [ 1428239782088 ]
          Mark Thomas made changes -
          Workflow jira [ 12726449 ] Default workflow, editable Closed status [ 12757401 ]
          Mark Thomas made changes -
          Project Import Mon Apr 06 01:19:02 UTC 2015 [ 1428283142430 ]
          Mark Thomas made changes -
          Workflow jira [ 12964738 ] Default workflow, editable Closed status [ 13001750 ]
          Mark Thomas made changes -
          Assignee Lukas JOSEFIK [ lukas ] Lukas Theussl [ ltheussl ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          1348d 2h 20m 1 Lukas Theussl 29/Jul/09 10:28

            People

            • Assignee:
              Lukas Theussl
              Reporter:
              Paul Spencer
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development