Uploaded image for project: 'Maven Shade Plugin'
  1. Maven Shade Plugin
  2. MSHADE-253

NullPointerException if minimizeJar == true && packaging == pom

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.1.0
    • Labels:
      None

      Description

      NullPointerException is thrown if minimizeJar == true && packaging == pom

      Discovered when trying to configure shading a parent pom (With packaging == pom) so all submodules will shade using this configuration.

      Stack trace:

      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-shade-plugin:2.4.3:shade (*****) on project *****: Error creating shaded jar: null: NullPointerException -> [Help 1]
      org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-shade-plugin:2.4.3:shade (*****) on project *****: Error creating shaded jar: null
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
      	at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
      	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
      	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
      	at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:498)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
      Caused by: org.apache.maven.plugin.MojoExecutionException: Error creating shaded jar: null
      	at org.apache.maven.plugins.shade.mojo.ShadeMojo.execute(ShadeMojo.java:540)
      	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207)
      	... 20 more
      Caused by: java.lang.NullPointerException
      	at java.io.FileInputStream.<init>(FileInputStream.java:130)
      	at org.apache.maven.plugins.shade.filter.MinijarFilter.<init>(MinijarFilter.java:94)
      	at org.apache.maven.plugins.shade.mojo.ShadeMojo.getFilters(ShadeMojo.java:814)
      	at org.apache.maven.plugins.shade.mojo.ShadeMojo.execute(ShadeMojo.java:446)
      	... 22 more
      

        Issue Links

          Activity

          githubbot ASF GitHub Bot added a comment -

          GitHub user aviemzur opened a pull request:

          https://github.com/apache/maven-plugins/pull/107

          MSHADE-253 NullPointerException if minimizeJar == true && packaging == pom

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/aviemzur/maven-plugins minimize-jar-pom-packaging-npe

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/maven-plugins/pull/107.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #107


          commit 2cb0fab0cd154498cf637e6b6c54a23b4be4ecf4
          Author: Zur, Aviem <azur@paypal.com>
          Date: 2017-03-10T12:56:20Z

          MSHADE-253 NullPointerException if minimizeJar == true && packaging == pom


          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/maven-plugins/pull/107

          bmargulies Benson Margulies added a comment -

          Merged.

          hudson Hudson added a comment -

          FAILURE: Integrated in Jenkins build maven-plugins #8902 (See https://builds.apache.org/job/maven-plugins/8902/)
          MSHADE-253 Replace deprecated assertions in test.
          This closes #107. (bimargulies: http://svn.apache.org/viewvc/?view=rev&rev=1788941)


            People

            • Assignee:
              bmargulies Benson Margulies
              Reporter:
              aviemzur Aviem Zur
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development