Uploaded image for project: 'Archiva'
  1. Archiva
  2. MRM-1767

When selecting a specific repository to browse, I get an error that I don't have sufficient privileges.

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.4-M3
    • Fix Version/s: 2.2.0
    • Component/s: browser
    • Labels:
    • Environment:
      SERVER:
      Archiva 1.4M4 (War)
      Tomcat 6
      CentOS 6

      CLIENT:
      Windows 7 x64
      Chrome

      Description

      When browsing the repository, the "Browse Repository" drop down used to show "All" by default, but in 1.4-M4 it is initially blank (see ArchivaBrowse1.PNG)

      When I click the drop down and select a repository, at first I see an error that I must be logged in or have sufficient privileges. If I am not logged in, I get a login prompt (see ArchivaBrowser2.PNG).

      If I am logged in as the Admin user, I just see the error "You need to be authenticated for this action or have more privileges" (see ArchivaBrowser3.PNG)

      If I simply reselect the repository from the drop-down box, it works most of the time (authenticated or not).

      After clearing my browser cache, it happens less often, but still does it.

        Attachments

        1. ArchivaBrowse1.PNG
          19 kB
          Jeff Vincent
        2. ArchivaBrowse2.PNG
          72 kB
          Jeff Vincent
        3. ArchivaBrowse3.png
          66 kB
          Jeff Vincent

          Activity

            People

            • Assignee:
              skygolanur Eric Barboni
              Reporter:
              predatorvi Jeff Vincent
            • Votes:
              2 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: