Uploaded image for project: 'Archiva'
  1. Archiva
  2. MRM-1433

@Override are on interface methods which is only possible in java 6

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.1
    • Fix Version/s: 1.4-M1
    • Component/s: None
    • Labels:
      None
    • Environment:
    • Flags:
      Patch

      Description

      @Override is on consumers methods that are from an interface. This won't compile under java 5, only java 6. Since the project's compiler plugin "source" version is set to java 5, I assume that this is a bug.

        Attachments

        1. override-patch.patch
          9 kB
          Jim Sellers

          Activity

            People

            • Assignee:
              brettporter Brett Porter
              Reporter:
              sellersj Jim Sellers
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: