Uploaded image for project: 'Maven Release Plugin'
  1. Maven Release Plugin
  2. MRELEASE-269

Check that 'new development version' is a SNAPSHOT version

    XMLWordPrintableJSON

    Details

    • Type: Wish
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-beta-6
    • Fix Version/s: 2.4
    • Component/s: prepare

      Description

      While executing 'mvn release:prepare' one gets asked for the new development version like this:
      What is the new development version for "foo"? (com.bar:foo) 1.12-SNAPSHOT:

      Say I want the new development version to be 2.0-SNAPSHOT (and not like suggested 1.12-SNAPSHOT) but by accident I only enter 2.0. This will work just fine until I want to execute 'mvn release:prepare' again at some later point. Then I will get the error message that the current version is not a SNAPSHOT version.

      It would be really nice if release:prepare could check if I have entered a valid SNAPSHOT version. If not release:prepare should fail or even nicer ask me to enter a proper SNAPSHOT version.

        Attachments

          Activity

            People

            • Assignee:
              rfscholte Robert Scholte
              Reporter:
              micmeyer Michael Meyer
            • Votes:
              4 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: